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1. Before You Start
This document contains general reference information and describes how to perform basic tasks while
working with product models. The product model is the main entity of the ODB++Design format, (also
referred to as “ODB++D” or “ODB++”). The product model stores all information about an electronic product
as an open, ASCII file structure.

Tip
You can download for free the ODB++Design format specification at https://odbplusplus.com/design.

List of Available ODB++ Viewer Documents........................................................................................ 1-2
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List of Available ODB++ Viewer Documents

Online Help provides documentation for all areas of the ODB++ Viewer functionality. To access the user
documentation from within your installed application, choose Help > Online Help or press F1.

Document Description

ODB++ Viewer User Guide The ODB++ Viewer interface enables you to interactively review
ODB++D product models.

List of Available ODB++ Viewer Documents
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2. Basic Tasks for Working With Product
Models

Use the instructions in this section to customize the display, navigate the graphic area, as well as search for
features and components based on their information.

Configuring the Display....................................................................................................................... 2-1
Zooming and Panning......................................................................................................................... 2-6
Measuring Distances........................................................................................................................... 2-9
Viewing Component and Feature Information..................................................................................2-12
Using the Component Filter Pane to Find Components.................................................................... 2-15
Using the Features Histogram to Select or Highlight Features......................................................... 2-16
Using the Components Histogram to Select or Highlight Components............................................ 2-18

Configuring the Display

A properly configured display is essential for the successful completion of your NPI tasks. You can
control the mouse pointer appearance, customize colors of various entities, and set display options for
components, features, layers, profiles, dynamic texts, and dimensions. You can specify update modes for
the Popup and histogram windows, as well as set units of measure in which distance values are displayed.

Procedure

1. Customize the colors in which the layers, background, rubberband, and selected and highlighted
items are displayed in the graphic area:

a. Open the Colors dialog box as appropriate for the application you are using.

b. Use one of the following methods to set colors:

Configuring the Display
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If you want to... Do the following:

Define colors for
entities

For each entity whose color you want to define, do
the following:

1. In the Entity pane, select the entity for which
you want to define a color: Layer 1 - Layer 25,
Background, Highlight, Select, or Rubberband.

2. In the Color Picker pane, select a color.

Tip
For best results, use a dark color for
the background, bright colors for layer
features and components, and light colors for
Rubberband, Highlight, and Select.

3. Click Apply.

Load a color scheme Prerequisite: A color scheme file exits.

1. Click Load.

2. Navigate to the directory in which you store
color scheme files.

3. Select the color scheme file and click Open.

4. Click Apply.

c. (Optional) Save the color scheme:

i. Click Save.

ii. Navigate to the directory in which you store your color scheme files.

iii. Name the file and click Save.

d. Click OK to apply the colors and close the dialog box.

Note
If you do not save the color scheme before checking in the product model, the scheme will
revert to the last saved scheme or to system default colors, if there is no saved scheme.

Note
The colors of overlapping objects in different displayed layers are mixed.

Note
The colors of Select, Highlight, and Rubberband are mixed with the layer colors or cover
them.

Configuring the Display
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2. Configure how data is displayed in the graphic area:

a. Open the Control dialog box as appropriate for the application you are using.

b. Specify how features are depicted by selecting one of the following Width options:

• On — 

• Outline — 

• Off — 

c. Specify whether negative data is dimmed or clear (erasing positive data).

d. Consider whether you want the color of a recently displayed layer to override underlying colors.
If so, set Layer Display Mode to Opaque.

e. To display only Step & Repeat outlines used in panelization and hide all features of selected
layers, set Step & Repeat Features Display to No.

f. Specify whether to display drills and rout data as pads or markers.

g. Specify whether to show the translated value of embedded code when displaying dynamic texts
or show only the code label.

h. Set the units of measurement for displaying distance values to Inch/mils or mm/microns.

i. If you want the Popview window to update continuously, set Popview Continuous Mode to On.

j. If you want the Features Histogram to update continuously, set Features Histogram Auto
Update to Yes.

k. If you want the Slots Histogram to update continuously, set Slots Histogram Auto Update to Yes.

l. Set Graphic Cursor to Regular or Full Screen.

m. Specify whether to display chain layer features.

n. Specify whether to display the compensated rout layer in the Rout Profile Editor.

o. Set Dimension Msg Display to Yes if you want to display Rout Profile Editor messages reporting
invalid dimension links when source or destination elements are modified.

Configuring the Display
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p. To display Flow Solder and SMT direction indicators in the Overview pane, set FS & SMT
Direction Display to Yes.

Outline arrows indicate Flow Solder direction and solid arrows indicate SMT direction. T = top; B
= bottom.

• FT — Flow solder top

• FB — Flow solder bottom

• ST — SMT top

• SB — SMT bottom

q. Set Layer Profile Display to one of the following: Yes (grid of dots), Outline (dotted line
indicating the outline of the layer profile), or No.

r. Set Layer Zone Display to one of the following: Yes (solid color for rigid zones, pattern for flex
zone), Outline (solid line indicating the outline of layer zones), or No.

Configuring the Display
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s. Specify whether to show or hide the layer features that are completely outside of the profile of
the Step & Repeat elements inside a panel.

t. Close the dialog box.

3. If the Component Display Options dialog box is available, use it to set the component display options:

a. Select the appropriate Name Display option: RefDes, None, Manufacturer/MPN, CAD Part, CPN,
VPL Pkg, Package, IPN, BOM Pkg.

b. Set Font Size to 36, 30, or 24.

c. Consider whether you want the text to extend beyond the component and lead outline. If so,
select Yes under Overflow Text.

d. If you want to display component leads, select the appropriate Show Pins option: Mount, Lead
Edges, Lead Form, Geometry, Name, Extended Lead Form, Net.

Note
If the pin name of the package differs from that on the component, and Package is selected in
Name Display, the pin name displayed is that of the package and an X is displayed on the pin.

Note
If the pin is non-electrical, M (mechanical) is displayed on it. X indicates that the component
includes recommended pins.

e. (Prerequisite: Show Pins ≠ No) Select Yes to display the Pin #1 mark on component leads.

f. If you want to hide components that bear the .comp_ignore attribute, set Components Display
to “Placed Only”.

g. Define the component outline as Body, Envelope, or T-envelope:

Configuring the Display
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Tip
To better view spacing measurements, select the Envelope or T-envelope option.

h. To highlight component data before merging with VPL data, in addition to the VPL data, set
Pre-VPL Component Display to Yes.

i. (Optional) Click Set as Default to save the settings as the default.

j. Click Close to close the dialog box.

Related Topics

Colors Dialog Box
Control Dialog Box
Component Display Options Dialog Box

Zooming and Panning

You can use the menus, the toolbars, the mouse wheel, or the right mouse button to zoom in or out of a
specific point in the graphic area, to zoom to a specific area of the board, or to zoom home. In addition,
you can use the mouse wheel to pan to the center of the graphic area, and the right mouse button to open
the Control dialog box or undo a previous action. Some ODB++Design interfaces support the moving of
the center of the graphic area to specific coordinates and a magnified popview display of a section of the
board.

Zooming and Panning
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Procedure

1. Use the following actions to explore and interact with ODB++Design content:

If you want to... Do one of the following:

Zoom out • Choose View > Zoom Out.

• Click the Zoom Out tool .

• Right-drag diagonally up and to the right .

• Roll the mouse wheel up.

• Shift-click the mouse wheel.

Zoom in • Choose View > Zoom In.

• Click the Zoom In tool .

• Right-drag diagonally down and to the left .

• Roll the mouse wheel down.

• Click the mouse wheel.

Zoom to area • Choose View > Zoom Area and draw a rectangle around the
section of interest in the graphic area.

• Click the Zoom Area tool  and draw a rectangle around the
section of interest in the graphic area.

• Right-drag diagonally down and to the right, so that the start and
end of the line you drag define the rectangular area to which you

want to zoom .

• (If available Use the popview display to magnify sections of the
board:

1. Click the Popview tool .

2. Draw a rectangle around the section of the graphic area you
want to display in the popview.

3. Draw a second rectangle to define the popview window.

You can move this rectangle to a convenient location. You can
enlarge or shrink it.

Zooming and Panning
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If you want to... Do one of the following:

The rectangular section of the graphic area is displayed in the
popview window.

The corners of the two rectangles are connected by lines.

4. (Optional) Change the area displayed in the popview by
dragging the source rectangle.

5. (Optional) Repeat Steps 1.b through 1.d for each section of
the board you want to magnify.

6. (Optional) Print the last opened popview display by pressing
Ctrl-P.

7. (Optional) To close the popview and display the area in the

Editor, click Goto Editor and Zoom  on the Popview
window.

Tip
You can use the Popview window to examine violations in
the Results Viewer, capture Sharelist images, and synchronize
between the BOM table in the Viewer window and the graphic
display.

Zoom home • Choose View > Zoom Home.

• Click the Zoom Home tool .

• Right-drag on the diagonal up and to the left .

• Ctrl-click the mouse button. A second Ctrl-click returns to the
previous view.

Pan • Click the appropriate pan tool:

Zooming and Panning
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If you want to... Do one of the following:

• Drag the mouse wheel in the direction you want to pan.

Move the center of the
graphic area to specific
coordinates

1. Choose View > Pan XY or click .

The Pan XY dialog box opens.

2. Type the X and Y coordinates to be the center of the graphic
area.

3. Click Goto.

2. (Optional) To cancel the most recent action, right-drag up, right, and down .

Related Topics

Zoom and Display Shortcuts

Measuring Distances

You can display orthogonal and diagonal measurements between points on the same, or different, layers
by clicking one of the tools for measuring distances, and the respective start and end points.

Procedure

1. From the Layer List, display the layers containing the features or components between which you
want to measure the distance.

2. Click one of the measuring tools and select the respective points, by using one of these options:

If you want to... Do the following:

Measure the distance
between two points

Tip
It is convenient, and more accurate, to set Snap mode before
measuring.

Measuring Distances
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If you want to... Do the following:

1. Click the Measure Between Points tool ( ) and click the first
point. A measurement rubberband opens, displaying DX, DY
values.

2. Click the second point. The distance between the two points is
displayed in the Data Bar.

The example shows:

• DX=0.56009 (relative distance along the X axis)

• DY=0.20007 (relative distance along the Y axis)

• D=0.59475 (direct distance between the two points)

Measure the distance
between two
contours/features

Note
Both features must be in the current Work Layer. To measure the
distance between features from two different layers, set the first
layer as the Work layer and choose the first feature. Then set the
other layer as the Work layer and choose the second feature.

1. Click the Measure Between Contours/Features tool ( ) and
click the first feature.

2. If several features overlap at that location, select the specific
feature from the list.

3. Click the second feature.

Measuring Distances

2-10 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



If you want to... Do the following:

4. If several features overlap at that location, select the specific
feature from the list.

A measurement segment opens between the features. The
measurement is displayed below the graphic area in the Data
Bar.

This measures the actual distance between edges of the copper
existing between two features. If, for example, a pad has been
shaved, this measures between the real edges of the copper,
ignoring the negative (shave) feature.

Measure the distance
between the closest
points in two nets

Note
The selected nets must be closer than 100 mils.

1. Select No Zoom, Auto Zoom and Pan, or Pan Only.

2. Click the Measure Between Nets tool ( ) and click a feature in
one net.

3. Click a feature in another net.

Measure the annular
ring

The following procedure measures the width of an annular ring
between a feature in the Work layer (typically a drill layer) and a larger,
containing feature in another layer.

1. Set the layer containing the smaller feature as the Work layer.

2. Click the Measure Annular Ring tool ( ) and click once on the
smaller feature.

A measuring line is displayed, and the size, along with the names
of the layers, is displayed in the Data Bar.

Measuring Distances
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If you want to... Do the following:

Note
If you display more than two layers, the option measures
between the feature in the Work layer relative to all the other
layers (such as to the solder mask or the outer layer).

Related Topics

Shortcuts to Graphic Area Functions
Snap Dialog Box

Viewing Component and Feature Information

You can use the data bar or the corresponding Information window to view information about an item
selected or highlighted in the graphic area.

Procedure

1. Select or highlight an item in the graphic area.

Information for the item is displayed in the data bar (see the examples below).

If you select more than one feature or component, the data bar shows either the details of the
previously selected item, or the details of the currently selected item.

2. (Optional, CAM Compare and ODB++ Viewer) In the data bar, right-click and choose the Select All
popup menu item, or drag to select a section of the text in the data bar, and copy the selected text as
necessary.

3. (Optional, Graphic Station and Panel Designer) Shift-click the data bar to view a log of all
component/feature selections in the current session:

Viewing Component and Feature Information
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4. (Optional) Open the respective Info window to view additional details about the selected item. You
can select and copy the information in the Information dialog box as necessary.

5. (Optional) If active, click the View image/Datasheet button ( ) to view the component’s data on
the manufacturer’s website.

Examples

Component Information In the Data Bar

TOP #321 U24 Part: 4100-0001 Pkg: BGA_1760_.1MM 1760 Pins X=6.6929134 Y=1.5748031
L=1.6929134 W=1.6929134 H=0.137795 Rot=180.0 P=0.0393701

Where:

• Layer = TOP

• Index number = 321

• RefDes = U24

• Part number (CAD) = 4100-0001

• Package name (CAD) = BGA_1760_.1MM

• Lead count = 1760

• X (coordinate) = 6.6929134

• Y (coordinate) = 1.5748031

• Length = 1.6929134

• Width = 1.6929134

• Height = 0.137795

• Rotation = 180.0

• Pitch = 0.0393701

Viewing Component and Feature Information
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Feature Information in the Data Bar

plane_1,#8390,Pad(SMD Pad,Geometry = REC70X70,Pad Usage = toeprint,Padstack ID =
36420),X=4.5034488,Y=1.1658425,s70,POS Net=GND COMP=J14 PIN=4 PIN_TYPE=UU

Where:

• Layer = plane_1

• Index number = 8390

• Feature type = Pad

• (Attribute) Geometry = REC70X70

• (Attribute) Pad Usage = toeprint

• (Attribute) Padstack ID = 36420

• X (coordinate) = 4.5034488

• Y (coordinate) = 1.1658425

• Symbol = s70

• Polarity = POS

• Net = GND

• Component = J14

• (Component) Lead count = 4

• (Component) Lead type = UU

Note
Component and lead information is displayed only for features with a net property that are the result
of conversion of primitives describing the layout of the component leads. Running the Board Merge
action enables you to obtain the component and lead information for a feature that does not have a net
associated with it, assuming that there are netpoints to all toeprints.

Related Topics

Component Information Dialog Box
Feature Information Dialog Box
Shortcuts to Graphic Area Functions

Viewing Component and Feature Information
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Using the Component Filter Pane to Find Components

The Component Filter tool is used to isolate and view components by their most commonly used criteria
(RefDes, CPN, IPN, MPN, Package, VPL package, and pin name). The filtering options you specify in the tool
determine the selection of components in the specified layers.

Procedure

1. Choose Edit > Find Component or click the Find Component tool ( ) in the toolbar.
The Component Filter is displayed under the Overview area.

Note

The Select All ( ), Highlight All ( ), and Advanced buttons are only available when you
access the Component Filter pane from the Graphic Station.

2. (Optional) In the layer list, select the component layers to which the search should apply. If no
component layer is selected, the search applies to both top and bottom layers.

3. Select the component identifier to be used (RefDes, CPN, IPN, MPN, Package, or vPackage).
In the example, components are highlighted according to their Package name.

4. Type or select the specific component identifier you want to find.
In the example, components with Package name qfp208 are highlighted.

5. (Optional) To view a specific lead of the component, select its name from the list.

6. Click the forward arrow to view the first component that meets the criteria.

If Pin Name is left blank, clicking the forward arrow zooms the view to and highlights the first
component that meets the criteria.

If Pin Name is specified, clicking the forward arrow zooms the view to and highlights the specific lead
of the first component that meets the criteria.

7. Continue clicking the forward arrow to view all components that meet the criteria.

Using the Component Filter Pane to Find Components
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8. (Graphic Station only) To select all components that meet the criteria, click the Select All button

( ).
In the example, all components of Package qfp208 are selected.

9. (Graphic Station only) To highlight all components that meet the criteria, click the Highlight All
button ( ).
In the example, all components of Package qfp208 are highlighted.

10. (Optional, Graphic Station only) Click the Advanced button to set more extensive search criteria in
the Components Filter dialog box.

Using the Features Histogram to Select or Highlight Features

Applicable layer types: Standard, Drill, Rout

Each feature node in the features histogram represents all features of the same type (such as line or pad)
and polarity (POS or NEG) and symbol type (such as r18). You can select one or more feature nodes and
then perform an action on all features represented by those nodes (such as select or highlight).

Procedure

1. Open the Features Histogram dialog box as appropriate for the tool you are using.
The Features Histogram dialog box opens.

2. Make sure that the selected layer is an Affected layer or Work layer.

3. Perform the required actions:

If you want to... Do the following:

Locate a specific type
of features

1. Choose Edit > Search (Ctrl-S).

The Search Pattern dialog box opens.

2. (Optional) Select the Case Sensitive option.

3. In the Search Pattern field, type the name of a feature or a part of
the name.

4. Click Zoomin on previous measurement (<--),
Zoomin on next measurement (-->).

Using the Features Histogram to Select or Highlight Features

2-16 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



If you want to... Do the following:

The node of the histogram that contains the string is highlighted.

Select features of the
specified types

1. Use one of the following methods to select features of the
specified types:

• To select all features of a single type, click the node in the tree
and click Select.

• To select features of a range of feature types, drag the mouse
pointer over a range of nodes, or use shift-click to mark a range
of nodes, and click Select.

• To select dispersed records, shift-click each node and click
Select for each additional node.

The data bar displays the number of selected features.

2. (Optional) Repeat Step 3.a to add additional feature types to
selection.

3. (Optional) Click Unselect to remove from selection the type of
features to which the last selection action was applied.

4. (Optional) Right-click in the graphic area and choose the Clear
Select & Highlight popup menu item to clear all selected and
highlighted features.

Highlight features of
the specified types

1. Do one of the following:

• To highlight all features of a single type, click on the node in the
tree and click Highlight.

• To highlight features of a range of feature types, drag the
mouse pointer over a range of nodes, or use shift-click to mark a
range of nodes, and click Highlight.

• To highlight dispersed records, shift-click each node and click
Highlight for each additional node.

The data bar displays the number of highlighted features.

2. (Optional) Click Turn Off to clear features to which the last
highlight action was applied.

3. (Optional) Right-click in the graphic area and choose the Clear
Select & Highlight popup menu item to clear all selected and
highlighted features.

Refresh the Features
tree

Click Update.

The list is updated according to the currently existing features.

Using the Features Histogram to Select or Highlight Features
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If you want to... Do the following:

Expand the Features
tree

Click Expand All.

Collapse the Features
tree

Click Collapse All.

All the feature type nodes are collapsed.

Related Topics

Features Histogram Dialog Box

Using the Components Histogram to Select or Highlight Components

You can use the Components Histogram to select or highlight all instances of a component in the graphic
area.

Procedure

1. Right-click a component layer in the Layer List and choose Components Histogram.

The Components Histogram window opens.

Using the Components Histogram to Select or Highlight Components
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Note
The Select and Unselect buttons are available only when the selected layer is an Affected layer or
Work layer.

The Components Histogram shows the total number of components and leads in the layer, and the
number of components of each type.

The list of components in the Components Histogram is divided into sections:

Using the Components Histogram to Select or Highlight Components
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Section Description

Types Histogram Lists types of components and the number of each type. Types are
defined by the _comp_type user attribute or by the Type2 or Type1
system attribute.

Parts Histogram Lists part names as read from the EDA system.

CAD Packages
Histogram

Lists CAD package names as read from the EDA system.

Nets Histogram Lists nets (which have toeprints in the selected component layer) and
the number of toeprints of each net.

CPNs Histogram (BOM INFORMATION) Lists Customer Part Numbers.

IPNs Histogram (BOM INFORMATION) Lists Internal Part Numbers.

Manufacturer/MPNs
Histogram

(BOM INFORMATION) Lists Manufacturer part Numbers and their
manufacturer names.

VPL Packages
Histogram

(BOM INFORMATION) Lists VPL packages, each name beginning with an
asterisk (*).

BOM Packages
Histogram

(BOM INFORMATION) Lists BOM packages.

You can use the options on the View menu to move between the sections. For example, choose
View > Parts to view the Parts section.

2. Perform the required action.

If you want to... Do the following:

Locate a component Choose Edit > Search (Ctrl-S).

In the Search Pattern dialog box, type the reference name of a
component (or a part of the name).

Click the forward and backward arrows until the required component
name is selected in the Components Histogram.

Jump to a specific
line

Choose Edit > Go to Line (Ctrl-G).

In the Goto Line dialog box, type the number of the line to find, and
click Go.

The mouse pointer moves to the specified line.

Select components Perform the appropriate task.

• To select all components of a single type, click on the node in the
tree and click Select.

Using the Components Histogram to Select or Highlight Components
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If you want to... Do the following:

• To select components of a range of component types, drag the
mouse pointer over a range of nodes, or use shift-click to mark a
range of nodes, and click Select.

• To select dispersed nodes, shift-click each node and click Select for
each additional node.

The data bar displays the number of selected components.

Highlight
components

The Highlight function provides graphical information only and does
not “select” the marked components.

To highlight components in the graphic area, perform the appropriate
task.

• To highlight all components of a single type, click on the node in the
tree and click Highlight.

• To highlight components of a range of component types, drag the
mouse pointer over a range of nodes, or use shift-click to mark a
range of nodes, and click Highlight.

• To highlight dispersed nodes, shift-click each node and click
Highlight for each additional node.

The data bar displays the number of highlighted components.

Refresh the list To refresh the list in the histogram, if components have been added to
or deleted from the graphic area, click Update.

Deselect a
component

To deselect a component in the graphic area, mark the component in
the Component Histogram, and click Unselect.

Remove the highlight To remove the highlight from a component in the graphic area, mark
the component in the Component Histogram, and click Turn Off.

Using the Components Histogram to Select or Highlight Components
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3. General Reference
The following topics provide general reference information for working with the ODB++Design interfaces.

Shortcuts to Graphic Area Functions...................................................................................................3-1
Layer Parameters............................................................................................................................... 3-13
Layer Subtypes...................................................................................................................................3-14
Layer Attributes................................................................................................................................. 3-19

Shortcuts to Graphic Area Functions

You can use keyboard shortcuts and mouse clicks to navigate and control the graphic area.

Mouse Button Codes............................................................................................................................3-2
Graphic Area Shortcuts........................................................................................................................3-3
Control Dialog Box Shortcuts...............................................................................................................3-5
Zoom and Display Shortcuts................................................................................................................3-6
Feature and Component Selection Actions......................................................................................... 3-8
Snap Hot Keys.................................................................................................................................... 3-10
Matrix Shortcuts................................................................................................................................ 3-11

Shortcuts to Graphic Area Functions
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Mouse Button Codes

The mouse button codes used in the user interface.

Table 3-1: Mouse Button Codes

Mouse Button Code Description

M1 Single click the left mouse button.

M2 Single click the center mouse button on a 3-button mouse.

M3 Single click the right mouse button.

M1M1 Double-click the left mouse button.

M2M2 Double click the center button on a 3-button mouse.

On a 2-button mouse under Windows, double-click both buttons
simultaneously.

M3M3 Double click the right mouse button.

M1 M1 Two separated clicks of the left mouse button

Mouse Button Codes
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Graphic Area Shortcuts

These keys and mouse buttons are associated with graphic area functions.

Table 3-2: Graphic Area Shortcuts

Key or

Mouse Button Function

double-click Graphic execute.

Enter Graphic execute.

E Graphic execute.

N Selects the next feature (single edit operations and single select).

click Selects.

Esc

middle-click

middle-drag

• If a selection tool is active:

◦ Esc | middle-click — Deselects a feature.

◦ Esc | middle-click — Cancels a rectangle you have started to draw.

◦ Esc | middle-click — Cancels the last side you have drawn in a
selection polygon.

◦ Shift - (Esc | middle-click) — Deselects all features.

◦ Double middle-click on a selected feature — Deselects all features
with the same symbol.

• If no selection or area zoom tool is active:

◦ Esc | middle-click — Pans the click point to the center of the
graphic area.

◦ Esc | middle-drag up and right — Zooms out and centers the
graphic area at the release point (Zoom Out).

◦ Esc | middle-drag down and left — Zooms in and centers the
graphic area at the release point (Zoom In).

◦ Esc | middle-drag down and right — Zooms in on the defined
rectangular area (Zoom to Area).

◦ Esc | middle-drag up and left — Fits the board in the graphic area
(Zoom Home).

• If a rubberband is visible, terminates the rubberband display.

Graphic Area Shortcuts
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Table 3-2: Graphic Area Shortcuts (continued)

Key or

Mouse Button Function

• In the Copper/Exposed Measurement dialog box, cancels rectangle-
selection mode.

right-click Opens the popup menu for the area being clicked.

Graphic Area Shortcuts
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Control Dialog Box Shortcuts

These keys and mouse buttons can be used to perform graphic control functions.

Table 3-3: Control Dialog Box Shortcuts

Key Function

Ctrl-W Feature display width (outline)

Ctrl-N Negative data display mode

Ctrl-M Layer Display Mode

Alt-U Units

Alt-Y Layer Profile Display

Alt-Z Layer Zone Display

Related Topics

Control Dialog Box

Control Dialog Box Shortcuts
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Zoom and Display Shortcuts

These are the keys and mouse buttons associated with Zoom and Display functions.

Table 3-4: Zoom and Display Shortcuts

Key or
Mouse Button Function

Ctrl-F Refreshes the screen

F1 Opens online help

Home or Ctrl-H Zooms home

Page Up or Ctrl-I Zooms in

Page Down or Ctrl-O Zooms out

Ctrl-A Zooms selected area

double-click Zooms in and centers feature (zoom area icon selected)

Ctrl-double-click Zooms out and centers feature (zoom area tool selected)

Shift-double-click Zooms in double size and centers (zoom area tool selected)

Ctrl-Home Zooms to selected feature

Shift-Home Zooms to highlighted feature

Ctrl-Space Copies the current zoomed display to memory

Ctrl-Shift- Space Returns to the zoomed display in memory after zooming other areas

Ctrl-E Pans to mouse pointer position and centers

Right Arrow or Ctrl‑R Pans right

Ctrl-Shift-R Pans right with 90% overlap

Left Arrow or Ctrl-L Pans left

Ctrl-Shift-L Pans left with 90% overlap

Up Arrow or Ctrl-U Pans up

Ctrl-Shift-U Pans up with 90% overlap

Down Arrow or
Ctrl‑D

Pans down

Ctrl-Shift-D Pans down with 90% overlap

Zoom and Display Shortcuts
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Related Topics

Zooming and Panning
Graphic Area Shortcuts

Zoom and Display Shortcuts
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Feature and Component Selection Actions

Selection can be performed on a single feature or component, by drawing a rectangle or polygon around a
number of features or components, or by selecting a net and its features.

Feature Selection Shortcuts
Table 3-5: Feature Selection Shortcuts

Key or

Mouse Button Function

click Selects single feature.

click-N Selects the next contiguous feature.

Press N repeatedly until the feature you want is selected.

Used to select a feature in a densely populated area.

double-click Selects globally.

Shift-click Selects additionally.

middle-click Deselects single feature.

E

{Cursor-E}

• With highlight tool selected, highlights the feature under the mouse
pointer.

• With zoom area tool selected, selects with the rubber band.

Shift-middle-click Deselects globally.

Select by Rectangle Shortcuts
Table 3-6: Select by Rectangle Shortcuts

Key or

Mouse Button Function

click...click Selects features inside a rectangle (drag to opposite corner).

Shift-click...click Additionally selects features inside a rectangle (drag to opposite
corner).

Ctrl-click...click Selects inside and touching the polygon.

Shift-middle-click Deselects globally.

Feature and Component Selection Actions

3-8 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



Selection by Polygon Shortcuts
Table 3-7: Selection by Polygon Shortcuts

Key or

Mouse Button Function

click...click Selects features inside a polygon (drag to opposite corner).

Shift-click...click Additionally selects features inside a polygon (drag to opposite corner).

Ctrl-click...click Selects inside and touching the polygon.

Shift-middle-click Deselects globally.

Selection by Polygon Shortcuts
Table 3-8: Selection by Net Shortcuts

Key or

Mouse Button Function

click Selects all features of the electrical net.

Shift-click Selects all features of another electrical net.

Shift-middle-click Deselects globally.

Feature and Component Selection Actions
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Snap Hot Keys

This table describes the shortcut keys associated with the Snap function:

Table 3-9: Snap Shortcut Keys

Keys/Mouse button Function

SG Snap grid

SC Snap center

SE Snap skeleton

SA Snap advance

SI Snap intersect

SM Snap midpoint

SP Snap profile

SO Snap off

Ctrl+G Grid on/off

Related Topics

Snap Dialog Box

Snap Hot Keys
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Matrix Shortcuts

The Matrix window offers keyboard shortcuts and mouse click access in specific areas.

Table 3-10: Matrix Actions Menu Shortcuts

Keys Function

Ctrl-F Refreshes screen

Table 3-11: Key Combinations and Mouse Options for Layer View Navigation

Key
Ctrl
Combination Mouse Option Function

Home Ctrl-H Zoom home — display full
layer up to limits

PgUp Ctrl-I Press the scroll button and
drag the mouse to the right
and down.

Zoom in — enlarge view by
90%

PgDn Ctrl-O Press the scroll button and
drag the mouse to the left
and up.

Zoom out — reduce view by
90%

Ctrl-A Zoom area — click one
corner then opposite corner
of rectangle to display.

Ctrl-E Pan center of display to
cursor position

right_arrow Ctrl-R Pan right with 90% overlap

Shift-right_arrow Ctrl-Shift-R Pan right with 10% overlap

left_arrow Ctrl-L Pan left with 90% overlap

Shift-left_arrow Ctrl-Shift-L Pan left with 10% overlap

up_arrow Ctrl-U Pan up with 90% overlap

Shift-up_arrow Ctrl-Shift-U Pan up with 10% overlap

down_arrow Ctrl-D Pan down with 90% overlap

Shift-
down_arrow

Ctrl-Shift-D Pan down with 10% overlap

Matrix Shortcuts
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Related Topics

Matrix Window

Matrix Shortcuts
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Layer Parameters

In the product model Matrix, the layer parameter columns represent the basic layer characteristics: name,
type, subtype, context, polarity, reference, and dielectric reference.

Layers

Name of the layer selected in the matrix.

Type

The type assigned to a layer is indicated by the color of the layer row in the matrix:

• signal

• power_ground

• mixed

• solder_mask

• silk_screen

• solder_paste

• drill

• rout

• document

• mask

• dielectric

• conductive_paste

Subtype

Layer subtype from the list of subtypes available for the assigned layer type. See Layer Subtypes.

Context

Controls whether the layer is part of the physical board:

• board — Layers that are part of the physical board.

• misc — Any other layers, such as documentation and drill. These virtual layers contain information
about the board, but they do not correspond to physical layers on the board.

Layer Parameters
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Polarity

Positive or negative layer polarity.

In negative copper layers, features represent laminate instead of copper.

Reference

(Applicable to layer types solder_mask, solder_paste, silk_screen, mask, and conductive_paste) The layer
with type = signal, power_ground, or mixed, to which the features of the given layer are applied.

Dielectric Reference

The position of the copper layer to which the dielectric layer relates: none, above, below, both.

Reference layers for dielectric layers are always copper layers.

Related Topics

Matrix Window

Layer Subtypes

Some layer types have subtypes that support specific cases such as drill representation, flex and flex rigid
manufacturing, or embedded resistors and capacitors.

Standard Layer Subtypes................................................................................................................... 3-15

Layer Subtypes
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Standard Layer Subtypes

Standard layer subtypes available in the product model Matrix for various layer types.

Subtypes to Support Dielectric Layers

These layer subtypes support the dielectric layers:

Base Layer Type Layer Subtype Description

DIELECTRIC CORE Material that is pre-pressed layers according to a
pattern of copper foil - prepreg - copper foil.

PREPREG Material that is constructed with fiberglass
impregnated with resin. The resin is pre-dried,
but not hardened, and when heated, flows to
adhere to neighboring material.

Subtypes to Support Backdrill and Dual Diameter Drill

These layer subtypes support the possible unique needs of drill representation in product models:

Base Layer Type Layer Subtype Description

DRILL BACKDRILL Represents a backdrill procedure where the
plating within a hole is removed from the
unused portion of the matrix using a drill hole
slightly larger than the original. This removes the
connection from one side of the PCB.

DUAL_DIAMETER Represents a condition prior to plating where a
slightly larger hole is drilled part way through
the matrix at the same location as an existing
hole.

Subtypes to Support Flex/Rigid Flex Manufacturing

These layer subtypes support the unique needs of Flex/Rigid Flex product models:

Base Layer Type Layer Subtype Description

CONDUCTIVE_PASTE CARBON_MASK Defines the location where carbon ink is applied
to copper layers.

SILVER_MASK Defines the silver mask of the adjacent copper
layer.

Standard Layer Subtypes
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Base Layer Type Layer Subtype Description

DOCUMENT AREA Area definition.

DRAWING Drawing layer definition.

MASK BEND_AREA For labeling areas on the PCB bent when the PCB
is in use.

FLEX_AREA Stores the geometries of the flex portions of the
board.

RIGID_AREA Stores the geometries of the rigid portions of the
board.

IMMERSION_MASK Defines which features are to be covered during
immersion in the gold process.

OSP_MASK Defines which features are to be covered with
OSP finish.

PLATING_MASK Defines which features in the adjacent copper
layer should be plated.

STIFFENER Shapes and locations where stiffener material is
placed on the PCB.

FR4_STIFFENER FR4-based stiffener.

METAL_STIFFENER Metal-based stiffener.

POLYIMIDE_STIFFENE
R

Polyimide-based stiffener

FILM_SHIELDING Film-based shielding.

METAL_SHIELDING Metal-based shielding.

PSA Shapes and locations where PSA (Pressure
Sensitive Adhesive) material is placed on the
PCB.

MIXED MIXED_FLEX Mixed copper layer—a layer containing both
power/ground planes and regular signal pads
or traces—on flex laminate. Used to distinguish
from a Mixed copper layer on rigid laminate in a
rigid-flex board.

POWER_GROUND PG_FLEX Power and ground (copper) layer on flex
laminate. Used to distinguish from power and
ground layer on rigid laminate in rigid-flex
boards.

ROUT PUNCH Pattern to be punched by a die-cut fixture.

Standard Layer Subtypes
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Base Layer Type Layer Subtype Description

SIGNAL SIGNAL_FLEX Signal (copper) layer on flex laminate. Used to
distinguish from signal on rigid laminate in rigid-
flex boards.

SOLDER_MASK COVERCOAT Clearances of a covercoat layer.

COVERLAY Clearances of a coverlay layer.

LIQUID_PHOTO
IMAGEABLE

LPI solder mask region.

Subtypes to Support Embedded Resistors and Capacitors

These layer subtypes support the unique needs of product models containing embedded resistors and
embedded capacitors:

Base Layer Type Layer Subtype Description

MASK EMBEDDED_C Feature shapes on the layer represent embedded
capacitors.

EMBEDDED_R Feature shapes on the layer represent embedded
resistors.

Layer Subtype to Support Wire Bonding

This layer type supports wire bonding.

Base Type

TYPE Layer Subtype Description

MASK WIRE_BONDING Wire bond connections are stored in separate
layers for connections at the top and
bottom sides, named wire_bond_+_top and
wire_bond_+_bot.

In a wire bond layer, die bumps (pins of
source components) are represented by pads
bearing attributes .net_name, .comp_name,
and .pin_name (used as a link to the netlist file).

Wire bonds are represented by lines bearing
attribute .bonding_profile. The value of this
attribute specifies the bonding order.

Standard Layer Subtypes
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Base Type

TYPE Layer Subtype Description

Direct connection of die bump to copper pad (for
flip chip) is represented by lines of zero length.

Related Topics

Matrix Window

Standard Layer Subtypes
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Layer Attributes

Layer attributes add intelligence to the step data. You can control the display of the layer attribute columns
in the Matrix window by selecting or clearing the respective check boxes in the Layer Attributes pane.

Backdrill Max. Depth

The maximum allowable back drill depth.

Values: 0.0 - 100000.0 mils (0.0 - 2540000 mu)

Default: 0 mils (0 mu)

Backdrill not Penetrate Layer Name

Name of the layer not to be penetrated by the back drill.

Values: <0 - 64 characters>

Bulk Resistivity

The ohmic resistance of the semiconductor material.

Values: 0.0 - 100000 nano_ohm

Characteristic Impedance

The typical characteristic impedance (in ohms) required for a layer.

Values: 0.0 - 10000.0 Ohm

Default: 0 Ohm

Comment

Use for general textual comments.

Values: <0 - 500 characters>

Copper Area

The total copper-covered area on a layer of type signal, power_ground, or mixed within a single-board
step.

Layer Attributes
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The Matrix GUI displays both the copper area and its percentage of the total board area, but only the area
is stored as the attribute value.

Values: 0.0 - 2147483648^2

Default: Empty (not yet calculated)

Copper Thickness

The weight of copper according to its units of measure.

This layer attribute reflects the density of the copper used. Copper Thickness is measured in ounces per
square feet.

Values: 0.0 - 1000.0 oz/ft^2

Default: 0 oz/ft^2

The value is calculated as <layer_thickness>/<copper_weight>.

Where:

• layer_thickness — The value defined in EDA data for each layer. Each format may define this value using
a proprietary keyword or field.

• copper_weight — The layer thickness value divided by the value of the configuration parameter
copper_weight (default value = 1.35). This value reflects the density of the copper used.

Dielectric Constant (ER)

The ratio of the field without dielectric (Eo) to the net field (E) with dielectric. It is unitless and has a range
value of 1 for metals. Typical values are 4 and 5.

Values: 0.0 - 1000

Default: 0

Dielectric Thickness

For layers of type DIELECTRIC or SOLDERMASK, contains the thickness of material. For layers of type
SOLDER PASTE, contains the thickness of the metal mask (stencil). The value is in specified units of
measure.

Values: 0.0 - 500 mils (0.0 - 12700 mu)

Default: 0 mils (0 mu)

Layer Attributes
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Embedded Passive Technology

Assigns a technology type attribute to an embedded components layer.

Values: none | additive | subtractive

Default: none

HDI Assembly Technology

Type of HDI assembly technology identified in the product model. If None, the special layer is not created.

Values: none | wirebond | flipchip | hybrid

Default: none

HDI Layer Type

An attribute assigned to copper layers in an HDI design to indicate whether a layer is part of the core or
part of the buildup.

Values: buildup | core

Default: buildup

Value Assignment

The value is determined by the Subtype of the associated dielectric layer: buildup (dielectric Subtype =
prepreg) or core (dielectric Subtype = core).

The associated dielectric layer is the dielectric immediately above or below the copper layer that lists the
copper layer in its Dielectric Reference field. If both adjacent dielectric layers reference the same copper
layer, the HDI Layer Type is taken from the upper dielectric Subtype. If a copper layer is not listed as a
Dielectric Reference, the HDI Layer Type defaults to buildup.

Impedance Test Width

Test width of routes used for the provided impedance result.

Values: 0.0 - 100000 mils (0.0 - 2540000 mu)

Default: 0 mils (0 mu)

Layer Attributes
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Loss Tangent

The parameter of a dielectric material that quantifies its inherent dissipation of electromagnetic energy.

Values: 0 - 100

Default: 0

Related Topics

Matrix Window

Layer Attributes
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4. GUI Reference
This chapter describes the GUI elements that are common to all ODB++Design applications.

Matrix Window.................................................................................................................................... 4-2
Control Dialog Box............................................................................................................................... 4-6
Component Display Options Dialog Box............................................................................................ 4-12
Colors Dialog Box...............................................................................................................................4-17
Component Information Dialog Box..................................................................................................4-20
Feature Information Dialog Box........................................................................................................ 4-24
Features Histogram Dialog Box......................................................................................................... 4-30
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Matrix Window

To access:

• From the Engineering Toolkit: Click the matrix icon in the entity pane.

If the product model has no steps, the Create Step dialog box opens. Type the name of the step and click
OK or Apply.

• From Graphic Station, Panel Designer: Choose View > Matrix or click the Open Job’s matrix tool .

• From the Valor NPI dashboard: Click the Matrix tool  in the Layer Controls toolbar.

• From CAM Compare: Choose Tools > Matrix or click the Matrix tool .

• From ODB++ Viewer: Click the Matrix tool .

The Matrix represents the product model in which the rows are the product model layers (sheets on which
elements are drawn for plotting, drilling and routing, or assembly). You can customize the Matrix window
by moving the panes and toggling their display. The appearance settings are remembered for future Matrix
sessions.

Matrix Window
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Figure 4-1: Matrix Window

Objects

Object Description

Matrix rows Represent the layers in the product model step. The color reflects the layer
type. The positioning of the layers reflects the layer stackup:

• Top component, silk screen, solder paste, solder mask

• Copper layers in their order

• Solder mask, solder paste, silk screen, bottom component

• Drill layers in sequence from where the drills started, to the largest
depth (largest to smallest), then layer 2 to the largest depth, and so
forth

• Rout layers

• Document and misc layers

Matrix Window
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Object Description

If HDI technology layers are present in EDA data, they are displayed above
or below the relevant top or bottom component layers.

The color of the drag handle cell to the left of the name is colored green if
there are features on the layer.

Matrix columns Display the drill/rout spans and the values for the layer parameters and
attributes.

• Drill or rout spans — The left-most column represents the drill and rout
spans, with the arrows indicating the drill direction. This column cannot
be hidden.

There is a span bar for each drill and rout layer. The span bars appear as
solid lines, except for the layers with the subtype “backdrill” whose span
bars appear as dotted lines.

• Layer Parameters — The basic layer characteristics: Type, Subtype,
Context, Polarity, Dielectric Reference, and Reference. See Layer
Parameters.

Click a column header and drag to the desired location. The layer
parameter columns cannot be hidden.

• Layer Attributes — The layers' properties that add intelligence to the
product model data. Only the attributes selected in the Layer Attributes
pane display with values in the specified units.

Click a column header and drag to the desired location.

Layer Attributes

(View > Layer Attributes)

Lists the available layer attributes that you can display as the Matrix
columns. See Layer Attributes.

Select or clear the check box in the Show column to include or exclude the
layer attribute column from the Matrix.

Type a string in the Filter field to display only the attributes containing that
string in the Attribute or Values field.

Board View

(View > Board View)

Displays a thumbnail graphic of the layer selected in the Matrix. See Table
3-11 for the key combinations and mouse options for navigating and
controlling the display.

Matrix Window
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Usage Notes

• Choose File > Step and select the step to be displayed.

• If editing is enabled, choose File > Save or click  to save the product model, including the
modifications you have made in the Matrix.

• Choose Edit > Toggle Units or click  to switch between metric and imperial units.

• Choose View > Refresh or click  to refresh the screen display.

Matrix Window
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Control Dialog Box

To access:

• From Graphic Station, Panel Designer: Options > Graphic Control.

• From Valor NPI dashboard, DFMA Result Viewer: Tools > Options > Graphic Options.

• From CAM Compare, ODB++ Viewer: View > Control.

• Right-drag down and to the right in the graphic area ( ).

Use this dialog box to control the display of data in the graphic area.

Control Dialog Box
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Figure 4-2: Control Dialog Box

Fields

Field Description

Width Controls how features are depicted in the graphic area.

• On — Displays filled features

Control Dialog Box
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Field Description

• Outline — Displays outlines of features

• Off — Displays skeletons of features

Skeleton is the same as outline for all features except lines and arcs,
where the skeleton is a hairline through their centers from their start
point to their end point.

Ctrl-w toggles among the options.

Negative Data Controls how negative data and positive data displays in the graphic
area.

• Show Clear — Negative data erases positive data.

• Show Dim — Negative data displays dimmed.

Ctrl-n toggles between the options.

Layer Display Mode Controls whether layers are displayed in transparent mode or in opaque
mode in the graphic area.

• Transparent — Layers are transparent.

• Opaque — Layers are opaque. The color of a recently opened layer
overrides underlying colors.

Mixing of overlapping transparent layer colors depends on the
operating system.

Windows — Color mixing is non-realistic.

UNIX — Color mixing depends on the color representation. For True
Color, color mixing is non-realistic. For 8-bit, color mixing is realistic.

Ctrl-m toggles between the options.

Step & Repeat
Features Display

Controls the display when panelization has been performed on a
product model.

• Yes — Displays the panel and all features of selected layers in their
Step & Repeat sequences.

• No — Displays only Step & Repeat outlines used in panelization.

Drill/Rout Data
Display

Controls how drill and rout data is displayed.

• Regular — Shows pads in drill layers

Control Dialog Box
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Field Description

• Markers — Shows markers, instead of pads, indicating tool number
(Excellon files)

Marker symbols are customizable.

Dynamic Texts
Display

Controls how dynamic text is displayed.

• Value — Shows translated value of embedded code. Dynamic texts
can be accessed when adding text features

• Name — Shows code label only without its translated value

Units Controls the units of measurement in which distance values are
displayed.

• Inch/mils — Displays distances in inches or mils

• mm/microns — Displays distances in millimeters or microns

Alt-u toggles between the options.

Popview Continuous
Mode

Controls how the magnified view in the Popview window is refreshed.

• Off — Only when the user stops panning

• On — Continuously

Features Histogram
Auto Update

Controls how the features histogram is updated.

• Yes — Provides continuous update of the Features Histogram when
features are added or removed

• No — Updates the histogram when you click Update

Slots Histogram Auto
Update

Controls how the slots histogram is updated.

• Yes — Provides continuous update of the Slots Histogram when slots
are added or removed

• No — Updates the histogram when you click Update

Graphic Cursor Controls how the mouse pointer is indicated in the graphic area.

• Regular — As a plus sign (+)

• Full Screen — As cross hairs spanning the graphic area

Profile Display Controls the profile display.

• Yes — Displays profile

• No — Does not display profile

Control Dialog Box
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Field Description

Dimension Display Controls the display of distance indicators on lines in the Rout Profile
Editor.

• Yes — Display distance indicators

• No — Do not show dimension indicators

Chain Display Controls the display of chain layer features in the Rout Profile Editor.

• Yes — Display chain layer features.

• No — Do not display chain layer features.

Compensated Display Controls the display of the compensated rout layer in the Rout Profile
Editor.

• Yes — Display the layer.

• No — Do not display the layer.

Dimension Msg
Display

Controls the display of Rout Profile Editor messages reporting invalid
dimension links, when source or destination elements are modified.

• Yes — Display the messages.

• No — Do not display the messages.

FS & SMT Direction
Display

Controls whether arrows are superimposed in the Overview pane to
indicate top and bottom Flow Solder and SMT direction as set in the
entity attributes of the step.

• Yes — Display the arrows.

• No — Do not display the arrows.

The direction of the arrows viewed from the top layer toward the
bottom layer is determined by the step attributes. These are the
directions:

• left2right

• right2left

• top2bottom (vertical direction from the top edge to bottom edge of a
board)

• bottom2top (vertical direction from the bottom edge to top edge of a
board)

These are the step attributes:

Control Dialog Box
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Field Description

• SMT Direction (Bottom)

• SMT Direction (Top)

• Flow Solder Direction (Bottom)

• Flow Solder Direction (Top)

If the board is flipped or rotated, the display of arrows changes with the
board.

The default for this parameter is set in configuration parameter
edt_disp_fs_smt_direction.

Layer Profile Display Controls how the layer profile is indicated in the graphic area.

• Yes — The layer profile is displayed as a grid of dots.

• Outline — The outline of the layer profile is indicated by a dotted
line.

• No — The layer profile is not indicated (default)

Alt-y toggles among the options.

Layer Zone Display Controls how layer zones are indicated in the graphic area.

• Yes — Layer zones are displayed. The areas are labeled. Rigid zones
are a solid color and flex zones are displayed in a pattern.

• Outline — The outline of layer zones is indicated by a solid line.

• No — Layer zones are not indicated. (default)

Alt-z toggles among the options.

Related Topics

Configuring the Display
Control Dialog Box Shortcuts

Control Dialog Box

Getting Started With ODB++Design 4-11
Unpublished work. © 2026 Siemens Software Version 2604



Component Display Options Dialog Box

To access: View > Component Options

You can use the Component Display Options dialog box to configure some aspects of how components are
displayed in component layers.

Figure 4-3: Component Display Options Dialog Box

Fields

Field/Button Description

Name Display Defines the type of name or size to display for components.

• RefDes — Reference designator.

Component Display Options Dialog Box
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Field/Button Description

If the Placement Layer attribute is assigned, then its value appears
next to the component name, according to the following convention:

<RefDes>[<placement layer>]

The placement layer indication is for display only and does not affect
the component name.

• CAD Part — The part number from CAD data.

• Package — The package name from CAD data.

• None — Do not display a name.

• CPN — Customer Part Number from the BOM.

• IPN — Internal Part Number.

• Manufacturer/MPN — Manufacturer name and part number from
the BOM.

• VPL Pkg — Valor Parts Library package name.

• BOM Pkg — Package name from the BOM.

• Size — The X and Y dimensions of the package body. If the Minimum
or Maximum body tolerances are also selected, then the display
includes the difference between the nominal size and the minimum
or maximum size.

Body Tolerance Draws a dotted outline around the body of a VPL package to represent
the Nominal, Minimum, and Maximum dimensions as defined in the
VPL.

The body nominal shape is the same as the component shape, unless
the VPL packages are consolidated with the alternate ones (CPN mode),
or the maximum body tolerance was selected for the merge.

Font Size Defines the font size for the component and pin names.

Overflow Text Controls whether to allow text to extend beyond the component and
pin outline.

Show Pins Controls whether to display leads, and if displayed, the type of
information to show.

• No — Components display without leads.

• Yes — Components display with leads.

• Name — Lead name displays on the leads.

• Mount — Electrical Type/Mount Type information displays on the
leads.

Component Display Options Dialog Box
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Field/Button Description

◦ Electrical Type

The value is one of these:

• B (Electrical-Mechanical)

• E (Electrical)

• M (Non-electrical)

• U (Unknown)

◦ Mount Type

If VPL data exists, one of these displays:

• SMT

• SMT_RP (Recommended Pad: the lead size is determined by the
recommended exposed pad size and not by the lead geometry)

• TH

• TH_RH (Recommended Hole: the lead size is determined by the
recommended plated hole size and not by the lead geometry)

• PRESS_FIT

• HOLE (A physical hole that may miss physical terminal; can be
screw type)

• NON_BOARD (The lead is in the air)

If no VPL data exists, the value defined in the CAD data displays:

• smt

• th

• blind (partially through-hole, supported only by Mentor Neutral
file)

• osm (Other Side Mount: an SM lead placed on the opposite side
of the component).

• Lead Form — If VPL data exists, the shape is indicated on the leads:
A-Post Terminal, B-Butt or Ball, C-C-Bend, D-Lug, F-Flat Lead, G-Gull-
Wing, J-J-Lead, L-L-Bend, M-Column, N-Surface Lead, O-Pressfit, P-Pin
or Peg, Q-Quick Connect, R-Wraparound, S-S-Bend, T-Through Hole,
U-Bend, W-Wire, X-Other, Y-Screw.

• Extended Lead Form — If the VPL data contains the extended lead
form, the following information is displayed:

◦ On the leads: <Lead Form> / <Extended Lead Form>

Component Display Options Dialog Box
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Field/Button Description

◦ On the component sides: Classification used by analysis: leaded,
unleaded, onedge (treated as leaded), or pullback (treated as
unleaded)

• Lead Edges — If the VPL data contains the extended lead form, lead
edges are marked as follows:

◦ For standard SMT leads extending from the component body:
(s)ide, (t)oe, or (h)eel.

◦ For single-surface leads: p(eriphery).

◦ For concave wraparaound leads: i(nner periphery) or o(uter
periphery).

Note
Side information is missing for VPL components with no extended
lead form data. In this case, the lead edges are marked as (s)ide or
(a)mbiguous.

• Geometry — Leads are marked by their geometry (padstack name).

• Net — Leads are displayed with their net names.

Show Pins (Cont.) Controls whether to display leads, and if displayed, the type of
information to show.

• Size — The X and Y dimensions of the lead shape. If the Minimum
or Maximum lead tolerances are also selected, then the display
includes the difference between the nominal size and the minimum
or maximum size.

Lead Tolerance Draws a dotted outline around the leads of a VPL package to represent
the Nominal, Minimum, and Maximum dimensions as defined in the
VPL.

The pins nominal shape is the same as the pins shape unless the
maximum pins tolerance was selected for the VPL merge.

Show Pin #1 Mark Selected, displays the Pin1 mark.

Components Display Controls the display of components that have the .comp_ignore system
attribute.

• All — All components are displayed.

• Placed Only — Components with the .comp_ignore attribute are not
displayed.

Component Display Options Dialog Box
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Field/Button Description

This option affects several displays and functions in Valor NPI
dashboard, Graphic Station, Engineering Toolkit, and Export.

Component Outline Controls how the outline of the component body is displayed in the
graphic area.

• Body — As a solid line.

• Envelope — As a solid line with pins outlined by a dotted line. The
overall outline is the envelope.

• T-envelope — As a solid line with toeprints in outer layer outlined by
a dotted line. The overall outline is the T-envelope.

Pre-VPL Component
Display

Controls the display of original component data (from CAD) before
merging with VPL data, after VPL merge has been performed.

• No — Displays only VPL data, if present.

• Yes — Highlights component data before merging with VPL data, in
addition to VPL data (displayed but not highlighted).

If VPL merge has not been performed, both options display only pre-VPL
data.

3D TH Pin Protrusion
- IPC A610/7.3.3
Classes

Controls the length of TH lead protrusion in the 3D View based on IPC
Class 1, 2, or 3:

• 1 - Full length — The lead is not cut and displays as defined in the
VPL. (default)

• 2 - 2.5 mm (0.1″) — The lead is cut 2.5 mm from the end of the
board.

• 3 - 1.5 mm (0.06″) — The lead is cut 1.5 mm from the end of the
board.

Related Topics

Configuring the Display

Component Display Options Dialog Box
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Colors Dialog Box

To access: View > Color Settings

Use this dialog box to set colors for displaying entities in the graphic area: layers, the background, features
and components when you highlight or select them, and rubberband.

Figure 4-4: Colors Dialog Box

Description

The Color Picker pane displays the color for the entity selected in the Entity pane.

Colors Dialog Box
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Objects

Table 4-1: Colors Dialog Box - Entity Pane

Field Description

Layers Displays the color of features and components that reside in the layers
displayed in the graphic area. The layers are listed in the order of display
(Layer 1 - Layer 25). Click a layer to select it.

General Displays the color of the following entities:

• Background — The background of the graphic area

• Highlight — Features and components when you highlight them

( )

• Select — Features and components when you select them

( )

• Rubberband — The shape outline that dynamically tracks the mouse
pointer movement when you move a feature or a component

Click an entity to select it.

Table 4-2: Colors Dialog Box - Color Picker Pane

Field Description

Basic colors palette Displays pre-defined common colors as boxes. Click a color box: the
fields in the Color Picker pane are updated to reflect the change.

Custom colors
palette

Displays previously saved user-defined colors as boxes. Click a color box:
the fields in the Color Picker pane are updated to reflect the change.

Color picker Displays an array of colors. Click inside the field: the cursor changes to
crosshairs and the fields in the Color Picker pane are updated to reflect
the change.

Saturation slider Enables you to adjust the intensity of the selected color. Click and drag
the slider up or down: the fields in the Color Picker pane are updated to
reflect the change.

Custom color
rectangle

Displays a preview of the current color.

Color models Displays the HSL and RGB values for the current color.

HTML color code Displays the hex value for the current color.

Colors Dialog Box

4-18 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



Table 4-3: Colors Dialog Box - Action Buttons

Button Description

Pick Screen Color Enables you to pick a color from any region of your screen. Click
the button and then click the desired location: the cursor changes to
crosshairs and the fields in the Color Picker pane are updated to reflect
the selected color.

Add to Custom
Colors

Saves the current color to the Custom colors palette.

Load Loads a previously saved color scheme.

Save Saves the current color settings in a user-defined color scheme file at the
user, design center, or system level, or at any location on the file system.

The default name for a color scheme file is colors.

Default Reverts to the system default colors.

Apply Applies the current color to the selected entity. The color scheme
remains throughout the session.

OK Closes the dialog box and applies the color settings.

Cancel Closes the dialog box without changing the colors.

Related Topics

Configuring the Display

Colors Dialog Box
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Component Information Dialog Box

To access: Select or highlight a component in the graphic area and then perform the action appropriate for
your interface:

• Choose View > View Properties.

• Click the info tool  on the toolbar.

You can use the Component Information dialog box to view information about the component selected
or highlighted in the graphic area. The dialog box consists of the following panes: Identification,
DESCRIPTION, ATTRIBUTES, and PROPERTIES.

Component Information Dialog Box

4-20 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



Figure 4-5: Component Information Dialog Box

Objects

Object Description

Identification Lists the component identifiers derived from various sources.

Component Information Dialog Box
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Object Description

• Information in the CAD data:

◦ Layer — The layer in which the component resides.

◦ Index — The index number of the component.

◦ RefDes — The reference designator of the component.

◦ Part — The part number of the component.

◦ EDA Package — The name of the package.

• BOM INFO:

◦ CPN — The customer part number of the component.

◦ IPN — The internal part number of the component.

◦ Manufacturer — The manufacturer of the component.

◦ BOM Package — The name of the package.

• VPL INFO:

◦ MPN — The manufacturer’s part number of the matched part.

◦ Mcode — The name representing all variations of the
manufacturer’s name for the matched part.

◦ VPL Package — The name of the matched package in the VPL.

◦ Package Type — The type of the matched part’s package.

◦ Part SubType — The subtype of the matched part.

◦ Lead Type — The type of the matched part’s leads.

◦ Risk — The likelihood of creating a poorly soldered joint or the
entire component requiring rework. The value is the sum of the
risk scores of the various package geometry aspects (Position Type,
Package Type, Lead Form, Number of Leads, Pitch [for Package Type
= GA], and Package Size):

- Low (less than or equal to two)

- Medium (between two and four)

- High (greater than four)

View image/
Datasheet

(If available) Displays in a browser the component’s image and/or
datasheet on the manufacturer’s web site.

DESCRIPTION Lists the values in the description fields in the BOM: desc1...10.

ATTRIBUTES Lists the attributes with Entity = “Component” or “Package” that have
been assigned manually, at CAD input, or during analysis.

Component Information Dialog Box
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Object Description

In the Filter field, type a string to display only the attributes containing
this string in their name.

PROPERTIES Lists the properties in the Component and Package groups that have
been assigned at CAD input or during analysis.

In the Filter field, type a string to display only the properties containing
this string in their name.

Related Topics

Viewing Component and Feature Information

Component Information Dialog Box
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Feature Information Dialog Box

To access: Select or highlight a feature in the graphic area and then perform the action appropriate for
your interface:

• From Valor NPI dashboard, choose Edit > Feature Info.

• From Valor NPI dashboard, DFM Result Viewer, Graphic Station, Panel Designer, click the data bar.

• From any interface, click the info button ( ) in the toolbar.

You can use the Feature Information dialog box to view information about the feature selected or
highlighted in the graphic area. The dialog box consists of the following panes: Geometry, Attributes,
and Net Properties.

Description

Figure 4-6: Feature Information Dialog Box - Pad

Feature Information Dialog Box
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Figure 4-7: Feature Information Dialog Box - Line

Figure 4-8: Feature Information Dialog Box - Arc

Feature Information Dialog Box
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Figure 4-9: Feature Information Dialog Box - Surface

Objects

Table 4-4: Feature Information - Pad

Object Description

Geometry (Pad) Provides detailed information about the pad geometry.

See Figure 4-6.

• Layer — The layer in which the pad resides.

• Index — The index number of the pad.

• X, Y — The coordinates of the pad.

• Symbol — The symbol used to create the pad.

• Polarity — The polarity of the pad.

• Dcode — The Dcode of the pad.

• Angle — The angle of rotation of the pad.

• Mirror — The mirroring of the pad.

• Lead Form — The form of the lead associated with the pad.

Feature Information Dialog Box
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Table 4-4: Feature Information - Pad (continued)

Object Description

• Aspect Ratio — The ratio of the drill depth to its diameter. Displayed
only for round drill pads that have a non-zero radius and whose span
(cumulative thickness of the pierced copper and dielectric layers) is
greater than zero.

• Finished size — The size of the hole after plating, as determined by
the Drill Tool Manager (DTM) status:

◦ DTM applied — The Finish Size in the drill tool table.

◦ DTM not applied — The symbol value.

• Drilled size — The size of the tool used to create the hole, as
determined by the Drill Tool Manager (DTM) status:

◦ DTM applied — The Drill Size in the drill tool table.

◦ DTM not applied — No value is displayed.

Geometry (Line) Provides detailed information about the line geometry.

See Figure 4-7.

• Layer — The layer in which the line resides

• Index — The index number of the line

• XS, YS — The coordinates of the line start

• XE, YE — The coordinates of the line end

• Length — The length of the line

• Symbol — The symbol used to create the line

• Polarity — The polarity of the line

• Dcode — The Dcode of the line

Geometry (Arc) Provides detailed information about the arc geometry.

See Figure 4-8.

• Layer — The layer in which the arc resides

• Index — The index number of the arc

• XC, YC — The coordinates of the arc center

• XS, YS — The coordinates of the arc start

• XE, YE — The coordinates of the arc end

• Diameter — The arc diameter

Feature Information Dialog Box
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Table 4-4: Feature Information - Pad (continued)

Object Description

• Length — The arc length

• Symbol — The symbol used to create the arc

• Polarity — The polarity of the arc

• Dcode — The Dcode of the arc

• Sweep — The sweep angle the arc

Geometry (Surface) Provides detailed information about the surface geometry.

See Figure 4-9.

• Layer — The layer in which the surface resides

• Index — The index number of the surface

• XC, YC — The coordinates of the surface

• X Size, Y Size — The size of the surface in the X and Y directions

• Area — The area of the surface

• Perimeter — The total length of the surface contour

• Polarity — The polarity of the surface

• Dcode — The Dcode of the surface

• Islands — The number of islands contained in the surface

• Holes — The number of holes contained in the surface

• Edges — The number of edges contained in the surface

Shorted Nets Lists the names of the nets that are shorted together by the feature.

Note
Shorted nets information is only displayed for features defined in
the short definitions file as creating intentional net shorts within the
product model.

See Figure 4-7.

Attributes Lists the attributes that have been assigned to the feature at CAD input
or during analysis.

Net Provides the net information for the feature.

Feature Information Dialog Box

4-28 Getting Started With ODB++Design
Software Version 2604 Unpublished work. © 2026 Siemens



Table 4-4: Feature Information - Pad (continued)

Object Description

• In Figure 4-6, the Net GND is found on subnet #5172 of net #2. This
selected feature is a via. It is the first of the two features on the net.
(1/2).

• In Figure 4-7, the Net DATA_BIT_5 is found on subnet #3 of net #54.
This selected feature is a trace. It is the third of the five features on
the net. (3/5).

• In Figure 4-8, the Net DAT_RPD_2 is found on subnet #7 of net #351.
This selected feature is a trace. It is the first and only feature on the
net. (1/1).

• In Figure 4-9, the Net 12V_SW is found on subnet #14 of net #7. This
selected feature is a plane. It is the first and only feature on the net.
(1/1).

Net Attributes Lists the net attributes of the feature.

Net attributes are always shown in inch, regardless of the units specified.

Related Topics

Viewing Component and Feature Information

Feature Information Dialog Box
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Features Histogram Dialog Box

To access:

• From the Layer List, right-click a layer name in the Layer List and choose Features Histogram.

• From the Features Search/Features Filter window (Editor configuration), click the Select button, and
then click the Histogram button.

You can use the Features Histogram dialog box to select, highlight, or search for features residing in a layer
of type Standard, Drill, or Rout.

Figure 4-10: Features Histogram Dialog Box

Description

The behavior of the Features Histogram dialog box differs depending on how you invoke it:

• When invoked from the Features Histogram popup menu item, the dialog box displays all features
residing in the specified layer.

Features Histogram Dialog Box
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• When invoked from the Histogram button in the Features Search or Features Filter dialog box, the
dialog box displays only the selected features that match the filter criteria specified.

Tip
You can activate continuous update mode by setting the Features Histogram Auto Update option to Yes.
See Control Dialog Box.

Note
If you do not use feature selection tools, filters apply to all features in the Affected layers.

Objects

Table 4-5: Features Histogram Dialog Box

Object Description

Feature tree The features of the layer appear as tree nodes, grouped by type (lines,
pads, surfaces, and text). For each feature, the following information is
displayed:

• Polarity

• Resize

• Degree of rotation

• Count

Select one or more nodes and click one of the action buttons.

Select Prerequisite: The selected layer is an Affected layer or Work layer.

Cumulatively selects all features of the type selected in the Feature tree.

Unselect Prerequisite: The selected layer is an Affected layer or Work layer.

Unselects all features of the type to which the last selection action was
applied.

Highlight

(2D View only)

Highlights all features of the type selected in the Feature tree.

Turn Off

(2D View only)

Removes highlighting from all features of the type to which the last
highlight action was applied.

Features Histogram Dialog Box

Getting Started With ODB++Design 4-31
Unpublished work. © 2026 Siemens Software Version 2604



Table 4-5: Features Histogram Dialog Box (continued)

Object Description

Update Refreshes the histogram to reflect the specified layer and filter criteria (if
applicable).

Expand All Expands the Feature tree to all levels.

Collapse Collapses the Feature tree.

Related Topics

Using the Features Histogram to Select or Highlight Features

Features Histogram Dialog Box
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Snap Dialog Box

To access:

• From Valor NPI dashboard, DFM Result Viewer: Edit > Snap

• From Graphic Station, Panel Designer: Options > Snap

• From any interface: Control Snapping tool ( )

You can use the Snap dialog box to control whether the grid is displayed, and in what form. You can
control how items snap to positions on the grid or to other items.

Figure 4-11: Snap Dialog Box

Description

Factors Affecting Snapping

Factor 1: Item Type

Snapping depends on the type of item selected, its snap point, and the distance to the nearest snap point.

Snap Dialog Box
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Table 4-6: Items to Which Snapping Applies

Item Snapping Location

Grid At grid intersections.

Feature Line, Pad, Surface (area, polygon), Arc — According to the current
Snap mode as shown in Table 4-8.

Text — To the beginning of the baseline: .

Reference layer in CAM
Compare

A reference layer affected by the Move Layer action is highlighted
with a rubber band. A click inside the rubber band sets the snap
point to one of the following:

• The mouse cursor position (Snap mode = Off)

• The closest board feature as shown in Table 4-8
(Snap mode ≠ Off)

Step in an assembly
panel (if Panelization
mode = Manual)

If Snap mode = Off, the selection of a step snaps to the nearest
vertex on the board profile if clicked inside the step in proximity,
otherwise, no snap is performed.

If Snap mode ≠ Off, snapping is performed as follows:

• Clicking inside a step snaps according to the current Snap mode
to the nearest board feature in the current Snap and Work layer.

• Clicking outside of a step snaps to the panel features of the
current Snap layer.

Factor 2: Snap Mode

The appearance of the Control snapping tool reflects the current snap mode.

Table 4-7: Snap Modes

Snap Mode
Appearance
of the Tool Shortcut Snap Location

Off SO Snap mode is off

Grid SG Nearest grid intersection

Center SC Center of a pad (end of an arc or line)

Snap Dialog Box
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Table 4-7: Snap Modes (continued)

Snap Mode
Appearance
of the Tool Shortcut Snap Location

Skeleton SS Skeleton hairline in the center of a line or
arc, or to the center of a pad

Edge SE Closest edge of a feature (also lines and
arcs)

Intersect SI Intersection of lines or arcs

Midpoint SM Midpoint of lines (not arcs) or the center of
pads and filled surfaces

Profile SP Closest point on the defined profile

Between SB Center of an orthogonal (horizontal or
vertical) line between two closest pads

Factor 3: Snap Layer

Snapping only applies to items residing in the Snap layer, as selected with SA (Snap Advance). A small grid

symbol indicates that a layer is the Snap layer:

Snap Features
Figure 4-12: Snap Features

The snap points for a line, pad, surface, or arc depend on the specified Snap mode.

Table 4-8: Feature Snap Points Per Snap Mode

Snap
Mode Line Pad Surface Arc

Center to ends to center to center to ends

Snap Dialog Box
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Table 4-8: Feature Snap Points Per Snap Mode (continued)

Snap
Mode Line Pad Surface Arc

Skeleton to skeleton to center to center to skeleton

Edge to closest edge to closest edge to closest edge to closest edge

Intersect to intersect no snap no snap to intersect

Midpoint to midpoint to center to center no snap

Snap Dialog Box
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Grid Display
Table 4-9: Grid Display

Appearance Option Image

Marks

Net

Dots

Objects

Table 4-10: Snap Dialog Box

Object Description

Snap Features Buttons to exclude features of specified types from snapping.

The initial state of the buttons is selected, that is you can
snap to features of all types. For example, if you click to
deselect the Arc button, then features in the display will not
snap to arcs.

Snap Mode Options to specify Snap mode as described in Table 4-7.

Grid Controls for setting the grid display.

• Off — Displays or hides the grid.

• Marks — Displays the grid as plus signs (+) at grid
intersections.

• Net — Displays the grid as horizontal and vertical lines.

• Dots — Displays the grid as dots at grid intersections.

Snap Dialog Box
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Table 4-10: Snap Dialog Box (continued)

Object Description

• X size, Y size — Specify the distances between grid
intersections along the X and Y axes.

Origin Changes the graphic origin to the clicked location in the
graphic area.

All items in the graphic area are displayed according to the
specified origin, without changing the origin of the product
model.

Prev Origin Reverts to the product model origin.

Related Topics

Measuring Distances
Snap Hot Keys

Snap Dialog Box
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View Orientation Dialog Box

To access:

• From Graphic Station: 

• From other viewers: Actions > View Orientation

Use the View Orientation dialog box to control the display orientation of the board.
Figure 4-13: View Orientation Dialog Box

Objects

Object Description

Rotate Clockwise

Rotates the board 90 degrees clockwise.

Rotate Counter-Clockwise

Rotates the board 90 degrees counterclockwise.

Mirror (Y axis)

Flips the board left to right (left/right mirror).

Mirror (X axis)

Flips the board top to bottom (mirror top/
bottom).

Rotation Indicates the board rotation.

View Orientation Dialog Box
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Object Description

Mirror Indicates whether the board has been flipped.

Reset Returns the display to the original orientation.

Usage Notes

When rotating or mirroring, the center of the display is always maintained in the center.

View Orientation Dialog Box
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5. Troubleshooting
Use this chapter to help fix issues that can occur when working with ODB++Design applications.

Cursor Distortion in Extend Mode on Windows...................................................................................5-1
Text Scaling Issues on Windows 10..................................................................................................... 5-1
Display Colors are Not Correct............................................................................................................. 5-2
Profile is Not Visible in Graphic Area................................................................................................... 5-2

Cursor Distortion in Extend Mode on Windows

In dual display setups, different scale settings between the screens may cause the mouse cursor to change
shape unexpectedly or become distorted. This occurs because each screen generates a cursor based on its
own scale.

Symptoms

For example, clicking a measuring tool and then moving the window to the other screen changes the
cursor shape into a fragmented arrangement of overlapping rectangular and circular blocks, making it
unrecognizable and difficult to use:

Solution

Repeat the action associated with the cursor to refresh the cursor appearance on the new screen. In the
case of the measuring tool, click it again after moving the window.

Text Scaling Issues on Windows 10

The menu text may appear too small on high-resolution monitors (such as laptops with 4K resolution).

Solution

Turn off the setting for fixing blurry apps:

1. Choose Start > Settings > System > Display.

2. Under “Scale and layout,” click Advanced scaling settings.

3. Under “Fix scaling for apps,” turn off the option “Let Windows try to fix apps so they’re not blurry.”

Cursor Distortion in Extend Mode on Windows
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Display Colors are Not Correct

Display colors in the Valor NPI Graphic Station are not what you expect.

Symptoms

• Selected features are not displaying in the chosen color.

• Graphic Station display colors are different from those defined.

Causes

The color of selected, highlighted, or overlapping features is usually a mixture of the defined display colors.

Solution

In UNIX, if you want the selection color, highlight color, and rubber band colors to be a separate and
consistent color, specify this in configuration parameter gui_color_no_mix.

In Windows, when Layer Display Mode = Transparent, layer features are given some transparency and the
colors of overlapping features are mixed. This helps to emphasize overlapping features. When Layer Display
Mode = Opaque, the colors are not mixed and the color specified for select, highlight, and rubber band is
used. See “Control Dialog Box” in Getting Started With ODB++Design.

Related Topics

Configuring the Display

Profile is Not Visible in Graphic Area

The profile may not display if the highlight color is close to the background color.

Symptoms

• The profile is not visible in the graphic area.

• Choosing Edit > Create > Profile does not seem to create a profile.

Causes

The profile color might be set to the same color as the background color.

Display Colors are Not Correct
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Solution

Choose Options > Colors.

In the Colors dialog box, compare the Background to the Highlight color that controls the profile color. If
they are the same, or very close, change one or the other.

Related Topics

Configuring the Display

Profile is Not Visible in Graphic Area
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Glossary of Valor NPI Terms

Alias

Alternate name used for a part manufacturer.

Assembly Merge

Consists of BOM Merge, VPL Merge (also referred to as Library Merge), and Board Merge.

see BOM Merge, VPL Merge, Board Merge

Board Merge

A stage of Assembly Merge that re-engineers EDA data, determining the features and nets connected to
each component pin. Same as Component linking.

see Assembly Merge

Board Mark

Marks placed on a board to indicate whether the board can be manufactured (good board mark) or not
(bad board mark).

BOM Merge

A stage of Assembly Merge that merges the BOM with the board.

see Assembly Merge.

Broken

Missing section of an electric circuit.

BTE

Valor NPI BOM Template Editor. Used to create templates for parsing a customer’s BOM input files from
their original format. You can use a single template to parse similar BOM files.

Alias
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Checklist

Set of DFx Analysis check actions and their results.

Chosen part

When an IPN has more than one part in the BOM, the Valor NPI BOM Manager chooses one of the parts as
the Chosen part. Users can override the system-defined Chosen part.

Component identifier

Any of the ways by which a component can be identified, such as: CPN, CAD-CPN, IPN, MPN, Package,
RefDes, Station, and Angle.

Component linking

Re-engineers EDA data, determining the features and nets connected to each component pin. Component
Linking can be performed on a Board or a PCA. Same as Board Merge.

Contour

A shape created by merging multiple features.

Design Center

A directory under $VALOR_DIR that represents a physical plant of the customer who provided the design to
be manufactured. The application can be customized for designs coming from a particular design center.

Drill span

The layers through which a drill passes.

Drill type

A drill attribute with one of these values:

• Via — Connects several layers.

• Non-Plated — Through-hole (TH) drill type without electrical connectivity.

• Plated — Through-hole (PTH) drill type with electrical connectivity. Used for components legs.

Checklist
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Feature data

A primitive that can be drawn on the layer: line, pad (a specific symbol flashed at a point), surface (a linear
path with a specific width), text.

Flattening

Displaying all data of a panel with multiple Step & Repeat sequences, as one step. This is necessary for
assembly machines that cannot process Step & Repeat information.

Library Merge

A stage of Assembly Merge that reads package data from the validated BOM, copies VPL packages from
the BOM package collection to the PCA package collection, and positions the packages on the PCA at their
RefDes location in the correct orientation. Same as VPL Merge.

see Assembly Merge.

Manufacturer

Name of the supplier of the part, provided in the imported BOM data.

Manufacturer Alias List

A list in the VPL used to establish the MCode for a manufacturer name listed in the BOM.

For example, the name Duck Instruments might be represented as any of these: Duck Instruments, Duck
Instr, D-I, DI.

The manufacturer alias list would list the alias DI for all variations of the manufacturer name:

Manufacturer MCode

Duck Instruments DI

Duck Instr DI

D-I DI

DI DI

When the system processes a BOM file, it matches any one of the Duck Instruments name variations with
the standard MCode (DI) as defined in the VPL. The result is that the BOM has a consistent Manufacturer
name list compatible with the VPL and with VPL-MPN numbers.

Feature data
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Matrix

In ODB++, a two-dimensional representation of PCB entities. Rows correspond to layers, and columns
correspond to steps.

MCode

An abbreviated name used in the VPL to represent all variations of the manufacturer name. The result
is that the BOM has a consistent Manufacturer name list compatible with the VPL and with VPL-MPN
numbers.

Net connectivity

Information about electrical nets and their reference to actual copper features.

ODB++Design (ODB++)

Open Data Base is a CAD/CAM format that captures all CAD/EDA database, assembly, and PCB fabrication
knowledge in a single, unified database.

ODB++(X)

An XML version of ODB++Design.

Part Number

Identifies a component uniquely, within a certain inventory.

Part Package

The geometric characteristics of a component/part. Several parts (unique part numbers) can have the
same package.

Placement sequencing

Determining the sequence in which the components are placed on the board.

Polarized

This BOM column indicates whether the orientation of the part is significant.

Matrix
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Preference

A rating for each alternate MPN of an IPN, to indicate which is preferred: Preferred, Qualified, Unknown
(default), NotQualified. This information is used to establish the Chosen part among alternate MPNs for an
IPN.

Profile

The PCB outline, typically defined in the CAD data and imported with the product model. It is normally
defined as the outline of the PCB and follows the route path.

Recommended pad

For parts lacking pin contact area data, recommended pads are provided. You can specify whether
packages with recommended pads are included. An asterisk is added to the end of the name in the BOM
Manager if the package contains recommended pads (for example, PDSO-C2/XX-L58W45T31*).

Same Net Spacing

Reports non-touching, non-text features belonging to the same layer, if they are closer than a predefined
parameter.

Set origin

After importing a CAD design, you can set the board origin to a different point. The origin can be set at a
corner or any other point on the board. Changing the origin offsets the coordinates of all features in the
graphic display.

SIP

Self-Intersecting Polygon.

Sliver in a copper plane

Area in which the spacing between two lines or a line and a component is so close that it can potentially
cause a short. Slivers can also be formed in the etch resist when a trace leaves a termination at an acute
angle. This sliver can then lift, causing a violation.

Stub

Unconnected line endpoint.

Preference
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VLM

The VPL Manager (VLM) application manages a local VPL database and the content retrieved from the
central Siemens VPL. VLM provides tools to search, modify, create, and update the VPL database and its
contents.

The VPL is typically accessed by specifying a component identifier, which includes the component
Manufacturer and the Manufacturer Part Number (MPN). The connection between manufacturer data,
part data and package data is maintained by the MCode and VPackage Name that are stored in each part
definition.

VPL

The Valor Part Library is a database containing the physical descriptions of components.

Replacing CAD-drawn component packages with geometrically accurate component packages ensures
accurate Design for Assembly (DFA) checks such as those performed using Valor products. In addition, the
accurate geometry serves as a basis for the Auto-Generation of SMT Machine part data.

The VPL provides accurate physical models of electronic components supporting footprint generation,
DFM, and NPI (New Product Introduction) operations. It includes VPL Manufacturers and VPL-MPNs. You
can work with a local VPL and with the remote VPL at Siemens.

VPL Manufacturer

Name of the manufacturer in the BOM after retrieval from the VPL.

VPL Merge

A stage of Assembly Merge that reads package data from the validated BOM, copies VPL packages from
the BOM package collection to the PCA package collection, and positions the packages on the PCA at their
RefDes location in the correct orientation. Same as Library Merge.

see Assembly Merge

VPL Package

Name of package in the BOM after retrieval from the VPL. This information is used to establish the Chosen
part among alternate MPNs for an IPN.

VLM
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Glossary of Electronics Industry Terms

Aperture file

A Gerber wheel file contains external Gerber information as lines of text, each representing one or more
Dcode descriptions. Dcodes contain the symbol information missing from the Gerber files, because Gerber
274D files refer only to position. Gerber 274X has the aperture file embedded in the layer files, making the
aperture file unnecessary.

see Dcode

Artwork

An accurately scaled configuration used to produce the artwork master or production master.

Assembly

The process of attaching electronic components to a PCB to create a PCA.

see also Fabrication

AVL

Approved Vendor List. A list of alternate (functionally equivalent) parts for each CPN that are acceptable to
the customer. At minimum, the list includes CPN, Vendor, MPN, with a relationship of many Vendor/MPN
combinations per CPN. The AVL can be part of the BOM or a separate file. If the BOM data and AVL data are
provided in separate files, you can import them to the same PCA and merge them.

see also BOM, CPL

Axial

Components whose two pins extend from opposite sides of the body along the horizontal axis of the body.

see also radial.

AXI

Automatic X-Ray inspection. Used to QC covered parts of a board, such as the pins of components.

Aperture file
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BGA

Components that have all their terminations on the bottom.

see also Component, DIP components

Board

Contains all the information associated with a printed circuit design.

see Rout.

Body

Main part of an electronic component, excluding its pins.

BOM

Bill of Materials. A list of parts to be placed on a board with details identifying each part and its placement
on the board. Normally contains Customer Part Number (CPN) and component location on the board
(Reference Designator).

see also AVL, CPL

Bottom

The bottom side of a PCB.

see also Top

Bridging

Unwanted electrical connectivity between two pads.

Broken net

An open net where a section has been disconnected.

CAD

Computer Aided Design. CAD data describes the locations of holes and conductors in terms of X and Y
coordinates, hole sizes, and others. It can contain electrical information and netlists. CAD data has more

BGA
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comprehensive information than CAM data. Shapes are recognizable, self-contained entities instead of
being a collection of lines.

see CAM, EDA

CAM

Computer Aided Manufacturing or Computer Assisted Manufacturing. Technology in which machinery
receives instructions from a computer. Often this data is in Gerber format. When CAD output is fed into the
CAM device and translated into instructions to the machinery, it is called CAD/CAM.

see CAD, EDA

Component

Electronic part attached to a PCB during PCA assembly.

see also BGA, DIP components

Conformal coating

A material (usually acrylic or silicon-based) that is sprayed over a populated PCB to prevent moisture
from causing problems with the electronics of the board. Usually, this is used for harsh environments
(Automotive, Military, Marine, and so on).

Copper balancing

Balancing the distribution of the copper density throughout and across the PCB to prevent bowing and
twisting during thermal processing.

CPL

Component Placement List. Holds the X, Y, angle, and side information for each RefDes to indicate
placement on the board.

see also AVL, BOM

CPN

Customer Part Number. CPN represents the part number requested by the customer ordering the board.
This can be the same as the IPN or can be mapped to a number of different IPNs depending on where the
CPN comes from.

see also IPN, MPN

CAM
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Dcode

The link between a symbol description and a specific aperture code in a Gerber file. This is defined in a
wheel. Dcodes control whether the light is on or off, and represent the aperture position on a list or wheel.

see Aperture file

DFA

Design For Assembly. The process of designing boards to simplify assembly, reduce errors, and lower
production costs. It involves considering component placement, orientation, spacing, and accessibility to
ensure machines or operators can assemble the board efficiently.

see also DFF, DFM, DFT, DFx

DFF

Design For Fabrication. The process of designing a product so that it can be fabricated efficiently at an
optimal cost. It is often used to represent both DFA and DFF.

see alsoDFA, DFM, DFT, DFx

DFM

Design For Manufacturing. Designing a product so that it can be fabricated efficiently at an optimal cost
and highest yield. It is often used to represent both DFA and DFF. The term is used to represent algorithms
that can make automated modifications to the PCA based on a set of rules.

see also DFA, DFF, DFT, DFx

DFT

Design For Test. The process of designing boards to facilitate testing and fault detection. It includes
features like test points, boundary-scan support, and accessible nets to make automated or manual testing
easier and more reliable.

see also DFA, DFF, DFM, DFx

DFx

Includes all the Design for methodologies such as DFA (Design for Assembly), DFF (Design For Fabrication),
and DFT (Design For Testing).

see also DFA, DFF, DFM, DFT

Dcode
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DIP components

Dual Inline Packages. Components that have two parallel rows of pins. The term started with through-hole
insertion DIPs, such as Proms, processors with two rows of pins inserted into holes. SMT DIPs are more
commonly referred to as SOICs—Small Outline Integrated Circuits and other similar packages.

see also Component, BGA, Through-hole

Dispenser

Machine that applies adhesive to SMT sites. Used to glue components to the bottom side of a board so
they remain in place during wave soldering.

DRC

Design Rule Check. Pass-or-fail checks based on design constraints. Normally used by EDA vendors.

EDA

Electronic Design Automation. Formats from which the application can receive CAD data.

see CAD, CAM

Fabrication

The work done as part of the actual fabrication of the copper layers and other actions performed on a
board before it is ready to receive parts (Drill, Signal, Solder Paste, Solder Mask, and others).

see also Assembly

Feeder

A device on an assembly machine that holds and supplies components for placement on the board.

see Feeder capacity

Feeder capacity

The number of feeder slots available on a machine.

see Feeder

DIP components
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Fiducial

A reference mark on a PCB used for alignment and registration during assembly and inspection processes.
Assists in the optical alignment of an assembly machine to the board. It can help compensate for slight
rotations of the board and in accurate placement of the component. There are three types of fiducials:

• Local fiducial — Relates to a component

• Global fiducial — Relates to a layer

• Panel — Relates to a panel

Footprint

The physical layout pattern of a component on a PCB, including the arrangement of pads and holes
required for mounting the component.

see Toeprint.

HDI

High-Density Interconnect. Refers to boards with very closely spaced components, fine-pitch leads, and
high pin counts. Uses advanced techniques such as microvias, additive processes, and other high-density
fabrication methods.

Inspection

Manual or AOI/AXI automated visual verification of quality, without electrical testing.

IPC

The Institute for Interconnecting and Packaging Electronic Circuits. The final American authority on
how to design and manufacture printed wiring. In 1999, IPC changed its name from the Institute of
Interconnecting and Packaging Electronic Circuits to IPC. The new name is accompanied by an identity
statement, Association Connecting Electronics Industries.

IPN

Internal Part Number. Identifies parts on the assembly floor for machine placement, ensuring the correct
components are supplied for board assembly.

see also CPN, MPN

Fiducial
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Island

Small copper residues. May be easily disconnected from the laminate, causing shorts in the circuitry.

Keepin/Keepout areas

These areas are normally imported with Gerber/EDA data. They define certain areas of a layer where
components and test points are allowed to be included or excluded. This enables the reporting of
components and test points that fall outside or within these areas.

Layers

Layers are two-dimensional sheets, containing graphics, attributes, and annotation. Layers represent
physical board layers, NC drills and rout layers, and miscellaneous drawings.

Lead

The pin of a component. Same as Pin.

Line

Ordered collection of assembly machines with their parameters.

Mount-type

How an electronic component is attached to a PCB.

see Technology, SMT, Through-hole

MPN

Manufacturer Part Number. The number used by the manufacturer to identify the part.

see also CPN, IPN

MPS

Manufacturing Process Simulation. The use of software to model and predict how a PCB or electronic
assembly will behave during production. It evaluates processes such as soldering, assembly, and testing to
identify issues like warping, solder bridging, thermal stress, or component placement errors before actual
manufacturing. The goal is to optimize the process, reduce defects, and save time and cost.

Island
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MSM

Machine Shape Management. Refers to the tools associated with the management of machine shapes.

NC

Assembly machine programming data in ASCII or binary format. NC program files are output from auto-
assembly sessions.

NC Data

ASCII language that assembly machines understand. Describes the machine setup.

Netlist

Net points and their connectivity definition, normally from the schematic.

NFP

Non-Functional Pad. A copper pad on a PCB that does not carry electrical signals or connect to the circuit.
It is included for mechanical support, alignment, or manufacturing reasons, such as improving soldering,
stabilizing the board, or facilitating via formation.

Nozzle

The part of the head on an assembly machine that picks up the parts from the feeder and lets go when
they are in place on the board.

NPI

New Product Introduction is the process used to handle new products at the assembly factory or designer
when they first arrive, to check that the boards can be assembled with minimal errors.

NPTH

Non-Plated Through Hole. A hole in a PCB that does not have a conductive plating on its walls. It is used for
mechanical purposes, such as mounting screws, standoffs, or connectors, rather than for making electrical
connections between layers.

see also PTH, Via

MSM
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OEM

Original Equipment Manufacturer. The original designer of a product or the company that has its label on
the product (for example, Sony, Cisco, Dell).

Package

Definition of the physical dimensions of an electronic component, without taking into consideration its
electrical properties.

Pad

A flat surface used to make electrical contact between a surface-mount device and a PCB.

see also Trace

Panel

A sheet of PCB containing several (similar or different) units (steps) that will be broken into individual
boards by a break operation. Same as Step&Repeat, S&R. Placement can follow a Step Repeat or Pattern
Repeat method.

Part

An electronic component to be attached to a PCB during assembly to produce a PCA.

PCA

Printed Circuit Assembly. Created by integrating BOM/AVL data with a board. You can create an empty
PCA and attach a board, or you can create a PCA from a board (you can create it with no BOM if you
are importing a separate BOM, or you can create it with a generated BOM extracted from the CAD part
numbers). The PCA is stored under a particular customer and design center.

PCB

Printed Circuit Board. A board typically made from fiberglass, used for mounting electronic components.
This board, also called a printed wiring board (PWB), has wiring patterns formed by traces of a conductor,
such as copper, fused to the board. These traces provide electrical connections for components that are
mounted on the surface of the PCB or through holes in the PCB. Examples: motherboard, SIMM, credit card
memory.

OEM
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Pin

A terminal on a component, whether SMT or through-hole. Also called a lead. Ball technology components
(such as BGSs, CSPs, and others) have ball terminations in place of pins. Same as Lead.

Pin One

The pin that indicates the orientation of the component.

see Pin

Pinhole

A tiny copperless gap surrounded on all sides by copper. Pinholes may cause electrical breaks, decreased
connectivity or undesirable electrical effects.

Pitch

Distance between the centers of a component's pins.

see Pin

PNS

Part Numbering System. The algorithm used to search part databases.

Power and Ground Layers

(P&G layers) Layers of copper that are fed by electrical voltage or are grounded.

see Stackup, Solder mask.

PTH

Plated-through Hole. A hole in a PCB that has a conductive metal layer on its walls, enabling electrical
connections between different layers. It can be used for component leads, vias, or interlayer routing.

see also NPTH, Via

Pin
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radial

Components whose leads extend from the same side of the component and whose pins usually form a
single line.

see also Axial

RefDes

Reference Designator. The unique name of a placed component. Each CPN can be placed several times on
a PCB; each placement has a unique RefDes.

Reflow soldering

A conduction soldering process that brings printed wiring assemblies into contact with heated air, infrared
radiation or both to melt solder paste. The result is to make the pads, pins, and solder paste one material.

Rotation

The orientation of a component on the PCA.

Rout

The line on which a PCA is cut to separate it from a board or panel.

see Board

SCM

Supply Chain Management. The process of managing the movement of materials between a company's
suppliers, internally in its operations, and out to its customers.

Shorted net

A net that is erroneously connected to another net.

SMD

Surface Mounted Device. A part put on the board which does not fit into any drill holes but rather connects
to pads on the board.

radial
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SMT

Surface Mount Technology. A method for attaching components to a PCA by placing them on the surface
of a PCB and then creating solder joints between the component's leads and the copper pads. Usually the
solder joints are created by placing the components on solder paste that has been screened on the PCB
and then passing it through a reflow oven. Alternately, the components can be glued to the board and
then the PCB can be passed through a wave solder machine.

SMT programming

The process of creating all the information required for an SMT machine to place all the required
components on a PCA. This includes the placement sequence information, the machine shape
information, and the feeder set-up data.

Solder mask

Plastic material spread on the copper of a circuit board except were the copper should be exposed, such as
the contacts to be soldered, the gold-plated terminals of any card-edge connectors, and fiducial marks.

see Stackup, Power and Ground Layers

Stackup

The layers of a board arranged according to a specific order.

see Solder mask, Power and Ground Layers

Step&Repeat

The repetition of a board on a panel. Same as Panel, S&R.

S&R

The repetition of a board on a panel. Same as Panel, Step&Repeat.

Technology

Type of component: MECH, SMT, THT.

see Mount-type, SMT, Through-hole

SMT
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Thieving pad (copper)

When copper features are placed on the outside of the board away from any other copper features (such
as fiducials), these will plate excessively during the pattern plating process. To reduce this, dummy copper
feature (or cross hatch patterns) will be placed close by, to thieve this excess plating and even out the flux
density in plating.

see also Thieving pad (solder)

Thieving pad (solder)

When wave soldering leaded SMT devices (such as SOICs) on the bottom of a PCB, a solder bridge will
often form between the last two leads of the device as it exits the wave. To prevent this, solder thieves are
placed on the board at the rear of the SOIC to thieve this excess solder away, preventing the bridge.

see also Thieving pad (copper)

Through-hole

THT technology assembly method of fitting wire leads of components into holes in the PCB. In the industry,
SMT has largely replaced THT.

see Mount-type, SMT, Technology

Toeprint

A copper pad on a PCB corresponding to a single component lead. For a one-lead component, the footprint
equals its toeprint. A footprint may consist of multiple toeprints for multi-lead components.

see Footprint

Tooling

The name given to those items unique to the PCB design that are necessary for manufacturing such as
films, drilling and routing data, and test fixtures.

Top

Top surface of a board.

see also Bottom

Thieving pad (copper)
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Trace

A line or arc forming a part of the electrical circuit.

see also Pad

Via

A hole in a PCB that electrically connects copper layers. It can be plated-through (PTH) to carry signals
between layers or non-plated for mechanical purposes. Vias allow routing in multi-layer boards without
using surface traces. Vias can be of these types:

• Through — From top to bottom.

• Blind — Drilled from one side, ending before reaching the other side. Cannot be seen from one of the
sides of the board.

• Buried — Connects two or more layers in the middle. It cannot be seen from either side of the board.
This is done by drilling the hole before the layers are attached.

see also NPTH, PTH

Trace
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