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Chapter 1
Before You Start

This document contains general reference information and describes how to perform basic tasks
while working with product models. The product model is the main entity of the ODB++Design
format, (also referred to as “ODB++D” or “ODB++"). The product model stores all information
about an electronic product as an open, ASCII file structure.

Tip
o You can download for free the ODB++Design format specification at
www.odbplusplus.convdesign.

Online Help ACCesS ..o vvitiintiiiiiiietieeeeeeosesosesessssssssnsssnsannss
Accessing Help From Your Installed Application . ............. ... ... ... .. ....
Searching PDFs with Acrobat Advanced Search .. ..............................

List of Available ODB++ Viewer DOCUIMENtS . ... ov vttt neeeeeeoonnaeenees

o OO0 OO0
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Before You Start
Online Help Access

Online Help Access

You can access the user documentation from within your installed application. You can search
for a string in all PDFs, using Acrobat Advanced Search. You can also access the Valor NPI
documentation from Support Center.

Accessing Help From Your Installed Application ..............cc0iiiiiiiinnnn. 8
Searching PDFs with Acrobat Advanced Search ............... ..., 8

Accessing Help From Your Installed Application

You can access help for all topics.
Procedure
1. Do one of the following:
e Choose Help > View Help.
e Press Fl.

2. (Optional) To display instructions for using the help system, click the Quick Help link
at the bottom of the help window.

3. (Optional) To open the InfoHub from an open document, click More Manuals and click
the InfoHub link at the bottom of the list of manuals.

Searching PDFs with Acrobat Advanced Search

You can search for a string across all of the PDFs in the InfoHub.

Prerequisites

Make sure that you have a recent version of Acrobat Reader installed on your computer. If not,
download from http://get.adobe.com/reader and install according to instructions.

Procedure

1. Navigate to the directory where the documentation PDFs are installed.

For example, C:\Mentor Graphics\Valor\VNPI_<ver>\edir\all\manual s\docs\pdfdocs.
2. Double-click any of the PDF files to open it in Acrobat Reader.
3. Choose Edit > Advanced Search.
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Before You Start
List of Available ODB++ Viewer Documents

The Search dialog box opens.

[ Search (= [ ]s)

ﬂ Srrange Windows

Where would ywou like to search?
1 Inthe current document
@ Al PDF Docurments ind

i by Docurmemnts -

What word or phrase would you like to
search faor?

[Tvidkhale wards arly
[] Case-Sensitive

[“IInclude Bookrmarks
[TlInclude Comments search

Showr bore Options

Find a word in the current document

4. Select the “All PDF Documents in”” option.

5. Click the down arrow and choose or browse to the directory where the documentation
PDFs are installed.

For example, C:\Mentor Graphics\Valor\VNPI_<ver>\edir\all\manual s\docs\pdfdocs.
6. Enter a string in the search box, and click Search.
The PDFs containing the search string are listed.

7. Expand the node of a PDF to list links to instances of the search string in the PDF.

List of Available ODB++ Viewer Documents

Online Help provides documentation for all areas of the ODB++ Viewer functionality.
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Before You Start
List of Available ODB++ Viewer Documents

Document Description

ODB++ Viewer User Guide | The ODB++ Viewer interface enables you to interactively
review ODB++D product models.
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Chapter 2
Common Operations

The basic tasks for working with product models include customizing the display, navigating
the graphic area, as well as searching for features and components based on their information.

Configuring the Display ........coiiiiiiiiiiiiiiiiireeeneenrenssnssnssnses 11
Zooming and Panning . .........iiiiiiiiiiiiiiiiititttttitttttttttttnsenes 17
Measuring Distances .. ......c.otiitiitiitiereereoreosenssssessnssnssnssnses 19
Viewing Component and Feature Information................ ..o, 22
Using the Component Filter Pane to Find Components ..................ocun.. 25
Using the Features Histogram to Select or Highlight Features.................... 26
Using the Components Histogram to Select or Highlight Components ............. 28

Configuring the Display

A properly configured display is essential for the successful completion of your NPI tasks. You
can control the mouse pointer appearance, customize colors of various entities, and set display
options for components, features, layers, profiles, dynamic texts, and dimensions. You can
specify update modes for the Popup and histogram windows, as well as set units of measure in
which distance values are displayed.

Procedure

1. Customize the colors in which the layers, background, rubberband, and selected and
highlighted items are displayed in the graphic area:

Feature in Layer 2

Highlighted Feature

Rubberband

a. Open the Colors dialog box as appropriate for the application you are using.

Getting Started With ODB++Design, vNPI 2305 1
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Common Operations
Configuring the Display

b. Use one of the following methods to set colors:

If you want to... Do the following:

Define colors for For each entity whose color you want to define, do
entities the following:

1. In the Entity pane, select the entity for which you
want to define a color: Layer 1 - Layer 25,
Background, Highlight, Select, or Rubberband.

2. In the Color Picker pane, select a color.

Tip: For best results, use a dark color for the

background, bright colors for layer features
and components, and light colors for Rubberband,
Highlight, and Select.

3. Click Apply.

Load a color scheme | Prerequisite: A color scheme file exits.

1. Click Load.

2. Navigate to the directory in which you store color
scheme files.

3. Select the color scheme file and click Open.
4. Click Apply.

c. (Optional) Save the color scheme:
1. Click Save.
ii. Navigate to the directory in which you store your color scheme files.
iii. Name the file and click Save.

d. Click OK to apply the colors and close the dialog box.

— Note
If you do not save the color scheme before checking in the product model, the

scheme will revert to the last saved scheme or to system default colors, if there is
no saved scheme.

Note
D The colors of overlapping objects in different displayed layers are mixed.

Note
The colors of Select, Highlight, and Rubberband are mixed with the layer colors

or cover them.

12 Getting Started With ODB++Design, vNPI 2305
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Common Operations
Configuring the Display

2. Configure how data is displayed in the graphic area:
a. Open the Control dialog box as appropriate for the application you are using.

b. Specify how features are depicted by selecting one of the following Width options:
o On—@ G
o Outline— () (O &

o Off —()

c. Specify whether negative data is dimmed or clear (erasing positive data).

d. Consider whether you want the color of a recently displayed layer to override
underlying colors. If so, set Layer Display Mode to Opaque.

e. To display only Step & Repeat outlines used in panelization and hide all features of
selected layers, set Step & Repeat Features Display to No.

f. Specify whether to display drills and rout data as pads or markers.

g. Specify whether to show the translated value of embedded code when displaying
dynamic texts or show only the code label.

h. Set the units of measurement for displaying distance values to Inch/mils or mm/
microns.

1. If you want the Popview window to update continuously, set Popview Continuous
Mode to On.

J. If you want the Features Histogram to update continuously, set Features Histogram
Auto Update to Yes.

k. If you want the Slots Histogram to update continuously, set Slots Histogram Auto
Update to Yes.

l.  Set Graphic Cursor to Regular or Full Screen.

m. Specify whether to display chain layer features.

Getting Started With ODB++Design, vNPI 2305 13
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Common Operations
Configuring the Display

n. Specify whether to display the compensated rout layer in the Rout Profile Editor.

o. Set Dimension Msg Display to Yes if you want to display Rout Profile Editor
messages reporting invalid dimension links when source or destination elements are
modified.

p- To display Flow Solder and SMT direction indicators in the Overview pane, set FS
& SMT Direction Display to Yes.

Outline arrows indicate Flow Solder direction and solid arrows indicate SMT
direction. T = top; B = bottom.

@)

o

@)

F'E

FT
ar
e
|

FT — Flow solder top

FB — Flow solder bottom
ST — SMT top

SB — SMT bottom

g. Set Layer Profile Display to one of the following: Yes (grid of dots), Outline (dotted
line indicating the outline of the layer profile), or No.

14
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Common Operations
Configuring the Display

r. Set Layer Zone Display to one of the following: Yes (solid color for rigid zones,
pattern for flex zone), Outline (solid line indicating the outline of layer zones), or
No.

Layer Zone Display = Yes

s. Specify whether to show or hide the layer features that are completely outside of the
profile of the Step & Repeat elements inside a panel.

t. Close the dialog box.

3. Ifthe Component Display Options dialog box is available, use it to set the component
display options:

a. Select the appropriate Name Display option: RefDes, None, Manufacturer/MPN,
CAD Part, CPN, VPL Pkg, Package, IPN, BOM Pkg.
b. Set Font Size to 36, 30, or 24.

c. Consider whether you want the text to extend beyond the component and lead
outline. If so, select Yes under Overflow Text.

d. Ifyou want to display component leads, select the appropriate Show Pins option:
Mount, Lead Edges, Lead Form, Geometry, Name, Extended Lead Form, Net.

_ Note
If the pin name of the package differs from that on the component, and Package

is selected in Name Display, the pin name displayed is that of the package and an
X is displayed on the pin.

Note
If the pin is non-electrical, M (mechanical) is displayed on it. X indicates that the

component includes recommended pins.
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May 2023

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.



Common Operations
Configuring the Display

e. (Prerequisite: Show Pins # No) Select Yes to display the Pin #1 mark on component
leads.

f. If you want to hide components that bear the .comp_ignore attribute, set
Components Display to “Placed Only”.

g. Define the component outline as Body, Envelope, or T-envelope:

Components Outline =  Components Outline = Components Outline =
T-envelope Envelope Body

1000 IR 0000

0000 B0.0.0 go0d0

Tip
o To better view spacing measurements, select the Envelope or T-envelope option.

h. To highlight component data before merging with VPL data, in addition to the VPL
data, set Pre-VPL Component Display to Yes.

Pre-\PL Component Display = Yes Pre-VFL Component Display = No

i. (Optional) Click Set as Default to save the settings as the default.
j. Click Close to close the dialog box.

Related Topics
Colors Dialog Box

16 Getting Started With ODB++Design, vNPI 2305
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Common Operations
Zooming and Panning

Control Dialog Box

Component Display Options Dialog Box

Zooming and Panning

You can use the mouse wheel or the right mouse button to zoom in or out of a specific point in
the graphic area, to zoom to a specific area of the board, or to zoom home. In addition, you can
use the mouse wheel to pan to the center of the graphic area, and the right mouse button to open
the Control dialog box or undo a previous action. Some ODB++Design interfaces support the
moving of the center of the graphic area to specific coordinates and a magnified popview
display of a section of the board.

Procedure

1. Perform the appropriate pan and zoom action:

If you want
to...

Do the following:

Zoom out

Use the following mouse movements:

e Right-drag diagonally up and to the right ( /f).
e Roll the mouse wheel up.
e Shift-click the mouse wheel.

Zoom in

Use the following mouse movements:

¢ Right-drag diagonally down and to the left ( }/ ).

e Roll the mouse wheel down.
e Click the mouse wheel.

Getting Started With ODB++Design, vNPI 2305
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Common Operations

Zooming and Panning

If you want
to...

Do the following:

Zoom to area

Use the following options:

e Right-drag diagonally down and to the right, so that the start and end
of the line you drag define the rectangular area to which you want to

zoom (\*).

e (If available) Use the popview display to magnify sections of the
board:

a. Click the Popview tool ( “f ).

b. Draw a rectangle around the section of the graphic area you want to
display in the popview.
c. Draw a second rectangle to define the popview window.

You can move this rectangle to a convenient location. You can
enlarge or shrink it.

The rectangular section of the graphic area is displayed in the
popview window.

The corners of the two rectangles are connected by lines.

d. (Optional) Change the area displayed in the popview by dragging
the source rectangle.

e. (Optional) Repeat Steps b through d for each section of the board
you want to magnify.

f. (Optional) Print the last opened popview display by pressing Ctrl-P.
g. (Optional) To close the popview and display the area in the Editor,
click Goto Editor and Zoom ( 7 |) on the Popview window.

18
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Common Operations
Measuring Distances

If you want | Do the following:
to...

Zoom home Use the following mouse movements:

e Right-drag on the diagonal up and to the left (‘\).

e Ctrl-click the mouse button. A second Ctrl-click returns to the previous

view.

Pan Drag the mouse wheel in the direction you want to pan.
Move the 1. Choose View > Pan XY or click it
center of the The Pan XY dialog box opens.
graphic area to
specific L pan xv - O %
coordinates

X |2.3483591 "oy : |1.7525405 ¢

Goto ‘

2. Type the X and Y coordinates to be the center of the graphic area.
3. Click Goto.

2. (Optional) To cancel the most recent action, right-drag up, right, and down ( }).

Related Topics

Zoom and Display Shortcuts

Measuring Distances

You can display orthogonal and diagonal measurements between points on the same, or
different, layers by clicking one of the tools for measuring distances, and the respective start and
end points.

Procedure

1. From the Layer List, display the layers containing the features or components between
which you want to measure the distance.
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Common Operations
Measuring Distances

2. Click one of the measuring tools and select the respective points, by using one of these

options:

If you want to... Do the following:
Tip: It is convenient, and more accurate, to set Snap mode before

Measure the distance

between two points measuring.

1. Click the Measure Between Points tool (5= ) and click the first
point. A measurement rubberband opens, displaying DX, DY
values.

2. Click the second point. The distance between the two points is
displayed in the Data Bar.

=-0.56009 ,!:—U . 2000?9:0. ha47h

The example shows:
e DX=0.56009 (relative distance along the X axis)
e DY=0.20007 (relative distance along the Y axis)
e D=0.59475 (direct distance between the two points)

20 Getting Started With ODB++Design, vNPI 2305
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Common Operations
Measuring Distances

If you want to...

Do the following:

Measure the distance
between two contours/
features

Note: Both features must be in the current Work Layer. To measure

the distance between features from two different layers, set the first
layer as the Work layer and choose the first feature. Then set the other
layer as the Work layer and choose the second feature.

1. Click the Measure Between Contours/Features tool (*]|) and
click the first feature.

2. If several features overlap at that location, select the specific feature

from the list.

Select All

#9215, Liners
#9216, Liners
#9222, Liners
#9223, Liners

d

3. Click the second feature.

4. If several features overlap at that location, select the specific feature
from the list.

A measurement segment opens between the features. The
measurement is displayed below the graphic area in the Data Bar.

This measures the actual distance between edges of the copper
existing between two features. If, for example, a pad has been
shaved, this measures between the real edges of the copper,
ignoring the negative (shave) feature.

/

Megative feature used in
shave

Measure the distance
between the closest
points in two nets

D Note: The selected nets must be closer than 100 mils.
1. Select No Zoom, Auto Zoom and Pan, or Pan Only.

2. Click the Measure Between Nets tool (=% ) and click a feature in
one net.
3. Click a feature in another net.
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Common Operations

Viewing Component and Feature Information

If you want to...

Do the following:

Measure the annular
ring

The following procedure measures the width of an annular ring
between a feature in the Work layer (typically a drill layer) and a
larger, containing feature in another layer.

1. Set the layer containing the smaller feature as the Work layer.
2. Click the Measure Annular Ring tool () and click once on the
smaller feature.

A measuring line is displayed, and the size, along with the names of
the layers, is displayed in the Data Bar.

D Note: If you display more than two layers, the option measures
between the feature in the Work layer relative to all the other
layers (such as to the solder mask or the outer layer).

Related Topics

Shortcuts to Graphic Area Functions

Snap Dialog Box

Viewing Component and Feature Information

You can use the data bar or the corresponding Information window to view information about
an item selected or highlighted in the graphic area.

Procedure

1. Select or highlight an item in the graphic area.

Information for the item is displayed in the data bar (see the examples below).

If you select more than one feature or component, the data bar shows either the details of
the previously selected item, or the details of the currently selected item.

2. (Optional, CAM Compare and ODB++ Viewer) In the data bar, right-click and choose
the Select All popup menu item, or drag to select a section of the text in the data bar, and
copy the selected text as necessary.

22
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Common Operations
Viewing Component and Feature Information

3. (Optional, Graphic Station and Panel Designer) Shift-click the data bar to view a log of
all component/feature selections in the current session:

Message = O !

Edit

sigt,#36l6,Pad (Geometry = v23_23 23 13,Pad Usage = wia),¥=1.35,¥=1.6,r23, Pil
s51gt, #4508,Pad (ICT Test Point,Gecmetry = v33 23 23 13,Pad Usage = via) ,¥X=1
s1gt, #1609, Pad (Geometry = £fid 0 0 0,Pad Usage = toeprint),X=0.65,¥=1.05,sl
sigt,#7868,Pad (ICT Test Poilnt,Gecmetry v33 23 23 13,prad Usage = via),X=2
51gt, #8323,Pad (ICT Test Point,Gecmetry = w33 23 23 13,Pad Usage via) ,®H=2
sigt, #7838, Pad (Geometry = v23 23 23 13,Pad Usage = via),¥%=2.45,¥=1.%,r23,P
sigt, #4555,Pad (ICT Test Point,Geometry = w33 23 23 13,Pad Usage = via),x=2
sigt, #8809, Pad (ICT Test Point,Geometry = v33 23 23 13,Pad Usage via],x=1:J

ol B R ERE o : g i

4. (Optional) Open the respective Info window to view additional details about the selected
item. You can select and copy the information in the Information dialog box as
necessary.

5. (Optional) If active, click the View image/Datasheet button (| ZE |) to view the
component’s data on the manufacturer’s website.

Examples

Component Information In the Data Bar

| TOF #321 U249 Paze: 41900-0001 Pkg: BGA_1760 . AMM 1760 Pina X=6,.682BFL34 Y=1.5748031 L=1.682B134 W=1.6820134 H=0.137783 ||

TOP #321 U24 Part: 4100-0001 Pkg: BGA 1760 .1MM 1760 Pins X=6.6929134
Y=1.5748031 L=1.6929134 W=1.6929134 H=0.137795 Rot=180.0 P=0.0393701

Where:

e Layer=TOP

e Index number = 321

e RefDes =U24

e Part number (CAD) =4100-0001

e Package name (CAD) =BGA 1760 .1IMM
e Lead count=1760

e X (coordinate) = 6.6929134

e Y (coordinate) = 1.5748031

e Length=1.6929134
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Common Operations
Viewing Component and Feature Information

e  Width=1.6929134
e Height=0.137795
e Rotation = 180.0

e Pitch=0.0393701

Feature Information in the Data Bar

| plane 1, #8380, Pad(5HMD Pad, Gecmetzy = RECTOXTO,Pad Usage = toeprine, Padstack ID = 36420) , X=4. 5034486, ¥=1_ 1652425, 870, PO3 |

plane 1,#8390,Pad(SMD Pad,Geometry = REC70X70,Pad Usage = toeprint,Padstack ID =
36420),X=4.5034488,Y=1.1658425,570,POS Net=GND COMP=J14 PIN=4 PIN_TYPE=UU

Where:

e Layer =plane 1

e Index number = 8390

e Feature type = Pad

e (Attribute) Geometry = REC70X70
e (Attribute) Pad Usage = toeprint
e (Attribute) Padstack ID = 36420
e X (coordinate) = 4.5034488

e Y (coordinate) = 1.1658425

e Symbol =570

e Polarity = POS

e Net=GND

e Component =J14

e (Component) Lead count = 4

e (Component) Lead type = UU

Note
Component and lead information is displayed only for features with a net property that are

the result of conversion of primitives describing the layout of the component leads. Running
the Board Merge action enables you to obtain the component and lead information for a feature
that does not have a net associated with it, assuming that there are netpoints to all toeprints.
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Using the Component Filter Pane to Find Components

Related Topics

Component Information Dialog Box
Feature Information Dialog Box

Shortcuts to Graphic Area Functions

Using the Component Filter Pane to Find
Components

The Component Filter tool is used to isolate and view components by their most commonly
used criteria (RefDes, CPN, IPN, MPN, Package, VPL package, and pin name). The filtering
options you specify in the tool determine the selection of components in the specified layers.

Procedure

1. Open the Component Filter pane as appropriate for the tool you are using:

If you are running this Do the following
tool...
Valor NPI dashboard 1. Ensure that the Board Overview pane is displayed

(View > Dock Widgets Display > Board Overview).
2. Choose Edit > Find Component or click the Find

Component tool ( @%) in the toolbar.

Valor NPI Graphic Station | Choose Edit > Find Component or click the Find

ODB++ Viewer Component tool ( @%) in the toolbar.

Panel Designer

The Component Filter pane is displayed under the Overview area.

gfpz08

") RefDes () CPN () Irm

() MPN @ Package () vPackage

“|»|®

.
e
)
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Common Operations
Using the Features Histogram to Select or Highlight Features

10.

Note

D The Select All (& ), Highlight All (<% ), and Advanced buttons are only available
when you access the Component Filter pane from the Graphic Station.

(Optional) In the layer list, select the component layers to which the search should
apply. If no component layer is selected, the search applies to both top and bottom
layers.

Select the component identifier to be used (RefDes, CPN, IPN, MPN, Package, or
vPackage).

In the example, components are highlighted according to their Package name.
Type or select the specific component identifier you want to find.

In the example, components with Package name qfp208 are highlighted.
(Optional) To view a specific lead of the component, select its name from the list.
Click the forward arrow to view the first component that meets the criteria.

If Pin Name is left blank, clicking the forward arrow zooms the view to and highlights
the first component that meets the criteria.

If Pin Name is specified, clicking the forward arrow zooms the view to and highlights
the specific lead of the first component that meets the criteria.

Continue clicking the forward arrow to view all components that meet the criteria.
(Graphic Station only) To select all components that meet the criteria, click the Select
All button (| @ ).

In the example, all components of Package qfp208 are selected.

(Graphic Station only) To highlight all components that meet the criteria, click the
Highlight All button (<2 ).

In the example, all components of Package qfp208 are highlighted.

(Optional, Graphic Station only) Click the Advanced button to set more extensive
search criteria in the Components Filter dialog box.

Using the Features Histogram to Select or
Highlight Features

Applicable layer types: Standard, Drill, Rout

Each feature node in the features histogram represents all features of the same type (such as line
or pad) and polarity (POS or NEG) and symbol type (such as r18). You can select one or more
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Using the Features Histogram to Select or Highlight Features

feature nodes and then perform an action on all features represented by those nodes (such as

select or highlight).

Procedure

1. Open the Features Histogram dialog box as appropriate for the tool you are using.

The Features Histogram dialog box opens.

2. Perform the required actions:

If you want to...

Do this:

Locate a specific type
of features

1.

2.
3.

4.

Choose Edit > Search (Ctrl-S).
The Search Pattern dialog box opens.

B search Pattern — O *

Search Pattern : |

<-—- —

[+ Case Sencsitiwve

(Optional) Select the Case Sensitive option.

In the Search Pattern field, type the name of a feature or a part of the
name.

Click Zoomin on previous measurement (<--),
Zoomin on next measurement (-->).

The node of the histogram that contains the string is highlighted.

Select features of the
specified types

1

. Make sure that the selected layer is an Affected layer or Work layer.
2.

Use one of the following methods to select features of the specified

types:

e To select all features of a single type, click the node in the tree and
click Select.

e To select features of a range of feature types, drag the mouse
pointer over a range of nodes, or use shift-click to mark a range of
nodes, and click Select.

e To select dispersed records, shift-click each node and click Select
for each additional node.

. (Optional) Repeat Step 2 to add additional feature types to selection.
. (Optional) Click Unselect to remove from selection the type of

features to which the last selection action was applied.

. (Optional) Right-click in the graphic area and choose the Clear

Select & Highlight popup menu item to clear all selected and
highlighted features.
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Using the Components Histogram to Select or Highlight Components

If you want to... Do this:

Highlight features of | 1. Do one of the following:

the specified types e To highlight all features of a single type, click on the node in the
tree and click Highlight.

e To highlight features of a range of feature types, drag the mouse
pointer over a range of nodes, or use shift-click to mark a range of
nodes, and click Highlight.

e To highlight dispersed records, shift-click each node and click
Highlight for each additional node.
2. (Optional) Click Turn Off to clear features to which the last
highlight action was applied.

3. (Optional) Right-click in the graphic area and choose the Clear
Select & Highlight popup menu item to clear all selected and
highlighted features.

Refresh the Features | Click Update.

tree The list is updated according to the currently existing features.

Expand the Features | Click Expand All
tree

Collapse the Features | Click Collapse All.
tree

All the feature type nodes are collapsed.

Related Topics

Features Histogram Dialog Box

Using the Components Histogram to Select or
Highlight Components

You can use the Components Histogram to select or highlight all instances of a component in
the graphic area.

Procedure

1. Right-click a component layer in the Layer List and choose Components Histogram.
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Using the Components Histogram to Select or Highlight Components

The Components Histogram window opens.

Top Components

Edit View

E Compenents Histogram

Total Pins

discrete
discrete&03
pihconn
pihmisc
plcc
printed
radial
smtconn
smtmisc
soic

sop

sot
tsoic

0%72663-0002
2220535-0003

Select

Total Components : 478

Types Histogram | 13)

(LS WS o T e WS o T T e 1S o T

Parts Histogram | 9a)

Highlight

Unselect

Off

Update

Note

The Select and Unselect buttons are available only when the selected layer is an

Affected layer or Work layer.

The Components Histogram shows the total number of components and leads in the

layer, and the number of components of each type.
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Using the Components Histogram to Select or Highlight Components

The list of components in the Components Histogram is divided into sections:

Section

Description

Types Histogram

Lists types of components and the number of each type. Types are
defined by the comp _type user attribute or by the Type2 or Typel
system attribute.

Parts Histogram

Lists part names as read from the EDA system.

CAD Packages
Histogram

Lists CAD package names as read from the EDA system.

Nets Histogram

Lists nets (which have toeprints in the selected component layer) and the
number of toeprints of each net.

CPNs Histogram (BOM INFORMATION) Lists Customer Part Numbers.

IPNs Histogram (BOM INFORMATION) Lists Internal Part Numbers.
Manufacturer/MPNs | (BOM INFORMATION) Lists Manufacturer part Numbers and their
Histogram manufacturer names.

VPL Packages (BOM INFORMATION) Lists VPL packages, each name beginning
Histogram with an asterisk (*).

BOM Packages (BOM INFORMATION) Lists BOM packages.

Histogram

You can use the options on the View menu to move between the sections. For example,
choose View > Parts to view the Parts section.

2. Perform the required action.

If you want to...

Do the following:

Locate a component

Choose Edit > Search (Ctrl-S).

In the Search Pattern dialog box, type the reference name of a
component (or a part of the name).

Click the forward and backward arrows until the required component
name is selected in the Components Histogram.

Jump to a specific
line

Choose Edit > Go to Line (Ctrl-G).

In the Goto Line dialog box, type the number of the line to find, and
click Go.

The mouse pointer moves to the specified line.
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Using the Components Histogram to Select or Highlight Components

If you want to... Do the following:
Select components Perform the appropriate task.

e To select all components of a single type, click on the node in the
tree and click Select.

e To select components of a range of component types, drag the mouse
pointer over a range of nodes, or use shift-click to mark a range of
nodes, and click Select.

e To select dispersed nodes, shift-click each node and click Select for
each additional node.

Highlight To highlight components in the graphic area, perform the appropriate
components task.

e To highlight all components of a single type, click on the node in the
tree and click Highlight.

e To highlight components of a range of component types, drag the
mouse pointer over a range of nodes, or use shift-click to mark a
range of nodes, and click Highlight.

e To highlight dispersed nodes, shift-click each node and click
Highlight for each additional node.

The Highlight function provides graphical information only and does not
“select” the marked components.

Refresh the list To refresh the list in the histogram, if components have been added to or
deleted from the graphic area, click Update.

Deselect a To deselect a component in the graphic area, mark the component in the

component Component Histogram, and click Unselect.

Remove the highlight | To remove the highlight from a component in the graphic area, mark the
component in the Component Histogram, and click Turn Off.
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Using the Components Histogram to Select or Highlight Components
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Chapter 3
General Reference

The following topics provide general reference information for working with the
ODB++Design interfaces.

Selection of Features Shaved With Negatives..............ciiiiiiiiiiiiiinnnn, 33
Regular Expressions for Search and Filtering ................ .o, 34
Shortcuts to Graphic AreaFunctions ........... .ot iiiiiiiiiiiiinrenrennnns 36
Layer Parameters ........cciuitiitiiiinrnnrenrenseosesssssessnssnssnsonses 43
Layer Subtypes. . . oo vvtiiiiiiiiiiiiitiietteteoseosssssssesssssnssnssnses 45
Layer Attributes. ... ..o ovviiiiiiiiiiiiiiitiiitenteoseosessessosssoscnssnsns 47

Selection of Features Shaved With Negatives

When a positive feature (copper) is overlaid with a negative feature (shaved), each of the
features can be selected individually. When selecting the positive feature, the whole feature is
selected including the shaved section.

Situation Illustration

Negative Line Drawn Over Pad (rubberband display) u

Negative Line Over Pad After Execution

Positive Pad After Being Selected

Only Negative Line Selected
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General Reference

Regular Expressions for Search and Filtering

Regular Expressions for Search and Filtering

The search and filtering functionality is available for most of the ODB++Design interfaces. The
search is case sensitive. You can use regular expressions to filter product models or product
model entities in Valor NPI Engineering Toolkit, or any component, feature, or attribute filter in
other interfaces. All regular expression rules apply. A regular expression contains syntax
elements metacharacters.

Table 3-1. Syntax Elements

Syntax Element

Name

Description

~

Tilda

Every regular expression begins with the tilda
(~) as in Perl.

[l

Square brackets

Specifies a list or range of characters.

~[akz] returns strings containing a, k or z (all,
alkaline, eazy)

~[2-5] returns strings containing 2, 3, 4 or 5.

0

Parentheses

Specifies an expression. You can use this
when the expression consists of more than one
character.

~T(5k)* returns strings starting with T and
containing 5k any number of times (T, T5k,
T5kxx, T5k5kx).

Table 3-2. Metacharacters

Metacharacter

Meaning

Description

Any single character

~c.t matches cat, cot, cut, cpt, and so on.

~a.... returns strings 5 characters long
beginning with a (apple, apply, abaca).

~1...5 matches strings 5 characters long
beginning with 1 and ending with 5.

One or more instances of the
preceding expression

~ca+t matches cat, caat, caaaaat

~m(iss)+ippi returns missippi and mississippi

Zero or one instance of the
preceding expression

~ca?t matches ct and cat.

~m(iss)?ippi returns mippi and missippi

Zero or more instances of the
preceding expression

~ca’*t matches ct, cat, caat, and so on.

~m(iss)*ippi returns mippi, missippi and
mississippi

34

Getting Started With ODB++Design, vNPI 2305
May 2023




General Reference
Regular Expressions for Search and Filtering

Table 3-2. Metacharacters (cont.)

Metacharacter Meaning Description

"] Any single character that is ~["53] matches any single character other than
not contained within the 5or3.
brackets

2l Any string beginning with a | ~*[53] matches any string beginning with 5 or
character that is inside the 3.
brackets

$ Ends in these characters ~sel$ matches strings ending in sel like

counsel, basel, diesel, and so on.
\ Turns a metacharacter into a | ~\$ matches strings containing §$.

character

Either of two conditions

~him|her matches strings containing either
him or her.
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Shortcuts to Graphic Area Functions

Shortcuts to Graphic Area Functions

You can use keyboard shortcuts and mouse clicks to navigate and control the graphic area.

Mouse Button Codes . .....coovtitiiiiiiiitiieiiieirieiesreasscnesscasncnenns 36
Graphic Area Shortcuts ........cociuiiiiiiieiiieirieieieeaseenenscasncncnns 36
Control Dialog Box Shortcuts. . .....coiiitiiiiiiiiiiiiiiieirieneneeannenenns 37
Zoom and Display Shortcuts. . .....ooiuiiiiiiiiiiiiiiiiiiirneneneeasnenenns 38
Feature and Component Selection Actions ..........civiiiiiiriiieiiinnnenenns 39
Snap HOt Keys .o iviuiiiiiiii ittt ittt iiitenenenesasasacnannnnns 41
Matrix Shortcuts . ....oviuiiiti ittt iiiiieitieiereensnenenscnnncnenns 41

Mouse Button Codes

The mouse button codes used in the user interface.

Table 3-3. Mouse Button Codes

Mouse Button Code | Description

Ml Single click the left mouse button.

M2 Single click the center mouse button on a 3-button mouse.

M3 Single click the right mouse button.

MIM1 Double-click the left mouse button.

M2M2 Double click the center button on a 3-button mouse.
On a 2-button mouse under Windows, double-click both buttons
simultaneously.

M3M3 Double click the right mouse button.

M1 M1 Two separated clicks of the left mouse button

Graphic Area Shortcuts

These keys and mouse buttons are associated with graphic area functions.

Table 3-4. Graphic Area Shortcuts

Key or Function
Mouse Button

double-click Graphic execute.
Enter Graphic execute.
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Table 3-4. Graphic Area Shortcuts (cont.)

Key or
Mouse Button

Function

E

Graphic execute.

N Selects the next feature (single edit operations and single select).
click Selects.

click or drag the e Terminates the rubberband display.

middle button ¢ If a selection tool is active:

e Middle-click — Deselects a feature.

e Middle-click — Cancels a rectangle you have started to draw.

e Middle-click — Cancels the last side you have drawn in a selection
polygon.

e Shift-middle-click — Deselects all features.

e Middle-double-click on a selected feature — Deselects all features
with the same symbol.

In the Copper/Exposed Measurement dialog box:

Cancels rectangle-selection mode.

Pans in the graphic area if no selection tool or area zoom tool is
active, and you are not in the Copper/Exposed Measurement dialog
box:

e Center in Graphic Area — Middle-click a point in the graphic area.
The click point is panned to the center of the graphic area.

e Zoom Out — With the middle button, drag a diagonal up and to
the right, ending at the point you want in the center of the graphic
area.

e Zoom In — With the middle button, drag a diagonal down and to
the left, ending at the point you want in the center of the graphic
area.

e Zoom to Area — With the middle button, drag a diagonal down
and to the right, so that the start and end of the line you drag define
a rectangular area to which you want to zoom.

e Zoom Home — With the middle button, drag a diagonal up and to
the left. The board is centered in the graphic area.

right-click

Opens a menu relevant to the area being clicked.

Control Dialog Box Shortcuts

These keys and mouse buttons can be used to perform graphic control functions.
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Zoom and Display Shortcuts

Table 3-5. Control Dialog Box Shortcuts

Key Function

Ctrl-W Feature display width (outline)
Ctrl-N Negative data display mode
Ctrl-M Layer Display Mode

Alt-U Units

Alt-Y Layer Profile Display

Alt-Z Layer Zone Display

Related Topics
Control Dialog Box

Zoom and Display Shortcuts

These are the keys and mouse buttons associated with Zoom and Display functions.

Table 3-6. Zoom and Display Shortcuts

Key or Function

Mouse Button

Ctrl-F Refreshes the screen
F1 Opens online help
Home or Ctrl-H Zooms home

Page Up or Ctrl-I Zooms in

Page Down or Ctrl-O | Zooms out

Ctrl-A

Zooms selected area

double-click

Zooms in and centers feature (zoom area icon selected)

Ctrl-double-click

Zooms out and centers feature (zoom area tool selected)

Shift-double-click

Zooms in double size and centers (zoom area tool selected)

Ctrl-Home Zooms to selected feature
Shift-Home Zooms to highlighted feature
Ctrl-Space Copies the current zoomed display to memory

Ctrl-Shift- Space

Returns to the zoomed display in memory after zooming other areas

Ctrl-E

Pans to mouse pointer position and centers
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Table 3-6. Zoom and Display Shortcuts (cont.)

Key or Function

Mouse Button

Right Arrow or Pans right

Ctrl-R

Ctrl-Shift-R Pans right with 90% overlap
Left Arrow or Ctrl-L | Pans left

Ctrl-Shift-L Pans left with 90% overlap
Up Arrow or Ctrl-U | Pans up

Ctrl-Shift-U Pans up with 90% overlap
Down Arrow or Pans down

Ctrl-D

Ctrl-Shift-D Pans down with 90% overlap

Related Topics

Zooming and Panning

Graphic Area Shortcuts

Feature and Component Selection Actions

Selection can be performed on a single feature or component, by drawing a rectangle or polygon
around a number of features or components, or by selecting a net and its features.

Feature Selection Shortcuts

Table 3-7. Feature Selection Shortcuts

Key or Function

Mouse Button

click Selects single feature.

click-N Selects the next contiguous feature.

Press N repeatedly until the feature you want is selected.

Used to select a feature in a densely populated area.

double-click Selects globally.
Shift-click Selects additionally.
middle-click Deselects single feature.
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Feature and Component Selection Actions

Table 3-7. Feature Selection Shortcuts (cont.)

Key or
Mouse Button

Function

E
{Cursor-E}

e With highlight tool selected, highlights the feature under the mouse
pointer.

e With zoom area tool selected, selects with the rubber band.

Shift-middle-click

Deselects globally.

Select by Rectangle Shortcuts

Table 3-8. Select by Rectangle Shortcuts

Key or
Mouse Button

Function

click...click

Selects features inside a rectangle (drag to opposite corner).

Shift-click...click

Additionally selects features inside a rectangle (drag to opposite corner).

Ctrl-click...click

Selects inside and touching the polygon.

Shift-middle-click

Deselects globally.

Selection by Polygon Shortcuts

Table 3-9. Selection by Polygon Shortcuts

Key or
Mouse Button

Function

click...click

Selects features inside a polygon (drag to opposite corner).

Shift-click...click

Additionally selects features inside a polygon (drag to opposite corner).

Ctrl-click...click

Selects inside and touching the polygon.

Shift-middle-click

Deselects globally.

Selection by Polygon Shortcuts

Table 3-10. Selection by Net Shortcuts

Key or
Mouse Button

Function

click

Selects all features of the electrical net.

Shift-click

Selects all features of another electrical net.

Shift-middle-click

Deselects globally.
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Snap Hot Keys

This table describes the shortcut keys associated with the Snap function:

Table 3-11. Snap Shortcut Keys

Keys/Mouse button Function

SG Snap grid

SC Snap center
SE Snap skeleton
SA Snap advance
SI Snap intersect
SM Snap midpoint
SP Snap profile
SO Snap off
Cul+G Grid on/off

Related Topics
Snap Dialog Box

Matrix Shortcuts

The Matrix window offers keyboard shortcuts and mouse click access in specific areas.

Table 3-12. Matrix Mouse Usage

Keys/ Function
Mouse Button
Click on a drag Selects a single layer
handle cell
Shift-click on a range | Selects a continuous range of layers
of drag handle cells
Ctrl-click on a drag | Adds a single layer to the current layer selection
handle cell
Click on a field Activates the field for editing
Tip

You can combine the Ctrl and the Shift keys to select multiple layers, some of which are
continuous ranges and others are single rows.
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Table 3-13. Matrix Editing Shortcuts

Keys Function

Ctrl-B Deletes row

Ctrl-C Copies row

Ctrl-I Inserts row

Ctrl-D Duplicates row

Ctrl-R Adds row
Note

The editing shortcuts are not supported in the read-only version of the Matrix.

Table 3-14. Matrix Actions Menu Shortcuts

Keys Function
Ctrl-F Refreshes screen
Table 3-15. Key Combinations and Mouse Options for Layer View Navigation
Key Ctrl Mouse Option Function
Combination
Home Ctrl-H Zoom home — display full
layer up to limits
PgUp Ctrl-1 Press the scroll button and | Zoom in — enlarge view by
drag the mouse to the right | 90%
and down.
PgDn Ctrl-O Press the scroll button and | Zoom out — reduce view by
drag the mouse to the left 90%
and up.

Ctrl-A Zoom area — click one
corner then opposite corner
of rectangle to display.

Ctrl-E Pan center of display to
cursor position

right arrow Ctrl-R Pan right with 90% overlap
Shift-right arrow | Ctrl-Shift-R Pan right with 10% overlap
left arrow Ctrl-L Pan left with 90% overlap
Shift-left arrow | Ctrl-Shift-L Pan left with 10% overlap
up_arrow Ctrl-U Pan up with 90% overlap
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Table 3-15. Key Combinations and Mouse Options for Layer View Navigation

Key

Ctrl
Combination

Mouse Option

Function

Shift-up_arrow | Ctrl-Shift-U

Pan up with 10% overlap

down_arrow Ctrl-D

Pan down with 90% overlap

Shift-

down_arrow

Ctrl-Shift-D

Pan down with 10% overlap

Related Topics

Matrix Window

Layer Parameters

In the product model Matrix, the layer parameter columns represent the basic layer
characteristics: name, type, subtype, context, polarity, reference, and dielectric reference.

Layers

Name of the layer selected in the matrix.

Type

The type assigned to a layer is indicated by the color of the layer row in the matrix:

signal
power_ground
mixed
solder mask
silk_screen
solder paste
drill

rout
document
mask
dielectric

conductive paste
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Subtype

Layer subtype from the list of subtypes available for the assigned layer type. See “Layer
Subtypes” on page 45.

Context

Controls whether the layer is part of the physical board:

e board — Layers that are part of the physical board.

e misc — Any other layers, such as documentation and drill. These virtual layers contain
information about the board, but they do not correspond to physical layers on the board.

Polarity
Positive or negative layer polarity.
In negative copper layers, features represent laminate instead of copper.

Reference

(Applicable to layer types solder mask, solder paste, silk screen, mask, and conductive paste)
The layer with type = signal, power ground, or mixed, to which the features of the given layer
are applied.

Dielectric Reference
The position of the copper layer to which the dielectric layer relates: none, above, below, both.
Reference layers for dielectric layers are always copper layers.

Related Topics
Matrix Window
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Layer Subtypes

Some layer types have subtypes that support specific cases such as drill representation, flex and
flex rigid manufacturing, or embedded resistors and capacitors.

Standard Layer Subtypes . .....ovtiitiiiiiiiiiiiiiittireeenrcnrsnrsnssnsnns 45

Standard Layer Subtypes

Standard layer subtypes available in the product model Matrix for various layer types.

Subtypes to Support Dielectric Layers
These layer subtypes support the dielectric layers:

Layer Subtype Base Layer Type Description

CORE DIELECTRIC Material that is pre-pressed layers according to a
pattern of copper foil - prepreg - copper foil.

PREPREG DIELECTRIC Material that is constructed with fiberglass

impregnated with resin. The resin is pre-dried,
but not hardened, and when heated, flows to
adhere to neighboring material.

Subtypes to Support Backdrill and Dual Diameter Drill

These layer subtypes support the possible unique needs of drill representation in product

models:

Layer Subtype

Base Layer Type

Description

BACKDRILL

DRILL

Represents a backdrill procedure where the
plating within a hole is removed from the unused
portion of the matrix using a drill hole slightly
larger than the original. This removes the
connection from one side of the PCB.

DUAL DIAMETER

DRILL

Represents a condition prior to plating where a
slightly larger hole is drilled part way through the
matrix at the same location as an existing hole.

Subtypes to Support Flex/Rigid Flex Manufacturing

These layer subtypes support the unique needs of Flex/Rigid Flex product models:

Layer Subtype

Base Layer Type

Description

AREA

DOCUMENT

Area definition.
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Standard Layer Subtypes

Layer Subtype Base Layer Type Description

BEND AREA MASK For labeling areas on the PCB bent when the
PCB is in use.

FLEX AREA MASK Stores the geometries of the flex portions of the
board.

RIGID AREA MASK Stores the geometries of the rigid portions of the

board.

CARBON MASK

CONDUCTIVE PA
STE

Defines the location where carbon ink is applied
to copper layers.

COVERCOAT SOLDER_MASK Clearances of a covercoat layer.

COVERLAY SOLDER_MASK Clearances of a coverlay layer.

DRAWING DOCUMENT Drawing layer definition

IMMERSION MAS | MASK Defines which features are to be covered during

K immersion in the gold process.

MIXED FLEX MIXED Mixed copper layer—a layer containing both
power/ground planes and regular signal pads or
traces—on flex laminate. Used to distinguish
from a Mixed copper layer on rigid laminate in a
rigid-flex board.

OSP_MASK MASK Defines which features are to be covered with
OSP finish.

PG FLEX POWER_GROUND | Power and ground (copper) layer on flex

laminate. Used to distinguish from power and
ground layer on rigid laminate in rigid-flex
boards.

PLATING MASK | MASK Defines which features in the adjacent copper
layer should be plated.

PSA MASK Shapes and locations where PSA (Pressure
Sensitive Adhesive) material is placed on the
PCB.

PUNCH ROUT Pattern to be punched by a die-cut fixture.

SIGNAL FLEX SIGNAL Signal (copper) layer on flex laminate. Used to

distinguish from signal on rigid laminate in rigid-
flex boards.

SILVER _MASK

CONDUCTIVE PA
STE

Defines the silver mask of the adjacent copper
layer.

STIFFENER MASK Shapes and locations where stiffener material is
placed on the PCB.
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Subtypes to Support Embedded Resistors and Capacitors

These layer subtypes support the unique needs of product models containing embedded resistors
and embedded capacitors:

Layer Subtype Base Layer Type Description

EMBEDDED C MASK Feature shapes on the layer represent embedded
capacitors.

EMBEDDED R MASK Feature shapes on the layer represent embedded
resistors.

Related Topics
Matrix Window

Layer Attributes

Layer attributes add intelligence to the step data. You can control the display of these columns
in the Matrix window by selecting or clearing the respective check boxes in the Layer Attributes
pane.

Backdrill not Penetrate Layer Name
Name of the layer not to be penetrated by the backdrill.
Values: <Freetext (0 - 64 characters)>

Bulk Resistivity
The ohmic resistance of the semiconductor material.
Values: 0.0 - 10000 nano_ohm

Characteristic Impedance
The typical characteristic impedance (in ohms) required for a layer.
Values: 0.0 - 10000.0 ohm
Default: 0 ohm

Comment
Use for general textual comments.

Values: <Freetext (0 - 500 characters)>
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Layer Attributes

Copper Thickness

The weight of copper according to its units of measure.

This layer attribute reflects the density of the copper used. Copper Thickness is measured in
ounces per square feet.

Values: 0.0 - 1000.0
Default: 0

Value Calculation
Copper Thickness is calculated as <layer_thickness>/<copper_weight>.

Where:

e layer_thickness — The value defined in EDA data for each layer. Each format may
define this value using a proprietary keyword or field.

e copper_weight — The layer thickness value divided by the value of the configuration
parameter copper_weight (default value = 1.35). This value reflects the density of the
copper used.

Value Display in the Valor NPI Product Model Matrix

Depending on the measurement units to which the display is set, the value of the layer attribute
Copper Thickness stored in the ODB++ product model may differ from the value displayed in
the Matrix window.

Measurement | Display Formula
Units
Imperial The value is rounded to the nearest 0.5 oz/ft"2.

e If the difference between the rounded value and the actual value
is less than 0.2, the rounded value is displayed as is.

e [f the difference between the rounded value and the actual value
is greater than 0.2, then it is rounded to the nearest two decimal
places.

Metric The value is displayed as is.

These examples use Cadence Allegro data with display in imperial units:

Example 1

SI001!TOP!POSITIVE!!YES!1!341000.000000 mho/cm!1/
10Z PLTD CU FOILINO!0.0921 w/cm-degC!1.600000 mil!CONDUCTOR!O!

In the layer TOP, LAYER THICKNESS = 1.6mil.
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This is divided by 1.35 to obtain a Copper Thickness of 1.18519 oz/ft"2. This is the value stored
in ODB++.

For display, this is rounded to the nearest 0.5 oz, giving a value of 1.0 oz/ft*2. Since the
difference between 1.18 and 1.0 is <0.2, the copper thickness value displayed is 1.

Example 2

S!011!BOTTOM!POSITIVE! !YES!1!580000.000000 mho/cm!ZOZ_COPPER!NO!0.0911 w/
cm-degC!2.400000 mil!CONDUCTOR!O!

In the layer BOTTOM, LAYER THICKNESS = 2.4mil.

This is divided by 1.35 to obtain a Copper Thickness of 1.7777 oz/ft*2. This is the value stored
in ODB++.

For display, this is rounded to the nearest 0.5, giving a value of 2.0 oz/ft"2. Since the difference
between 1.77778 and 2 is >0.2, the copper thickness value is rounded for display to two decimal
points = 1.78.

Dielectric Constant (ER)

The ratio of the field without dielectric (Eo) to the net field (E) with dielectric. It is unitless and
has a range value of 1 for metals. Typical values are 4 and 5.

Dielectric Thickness

For layers of type DIELECTRIC or SOLDERMASK, contains the thickness of material. For
layers of type SOLDER PASTE, contains the thickness of the metal mask (stencil). The value is
in specified units of measure.

Values: 0.0 - 500 ml | 0.0 - 12700 mu
Default: 0
Embedded Passive Technology
Assigns a technology type attribute to an embedded components layer.
Values: none | additive | subtractive
Default: none

HDI Assembly Technology

Type of HDI assembly technology identified in the product model. If None, the special layer is
not created.

Values: none | wirebond | flipchip | hybrid
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Default: none

HDI Layer Type

An attribute added to a copper layer, not a dielectric layer, to distinguish buildup layers from
core layers in HDI product models.

Values: buildup | core
Default: buildup

Value Assignment
The value depends on the dielectric layer Subtype and Dielectric Reference:

o [If the dielectric layer Subtype = prepreg, the associated copper layers determined by
Dielectric Reference are assigned HDI Layer Type = buildup.

e [If the dielectric layer Subtype = Core, the associated copper layers determined by
Dielectric Reference are assigned HDI Layer Type = core.

Impedance test width
Test width of routes used for the provided impedance result.
Values: -2147483648.0 - 2147483648.0 ml
Default: 0 ml

Loss Tangent

The parameter of a dielectric material that quantifies its inherent dissipation of electromagnetic
energy.

Values: 0 - 100
Default: 0

Related Topics
Matrix Window
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Chapter 4
GUI Reference

This chapter describes the GUI elements that are common to all ODB++Design applications.

Matrix WINAOWw . ..ottt it iiiitenrnenenscasocnosscnsacnnnss 52
Control Dialog Box . ...civiiiiiiiiiiiiiiiiiiiiiiiiiiitreasncnenscanncnenns 56
Component Display Options Dialog Box.........ccciiiiiiiiiiiiiiiiiiinnenenns 62
Colors DIalog BoX ..o vviiiiitiiiiiieitieneneenesesesssnsocnosscnsacnanns 66
Component Information Dialog Box .........cciiiiiiiiiiiiiiiiiiiiiienenenn, 69
Feature Information Dialog Box ..........coiiiiiiiiiiiiiiiiiiiiiineeneennns 72
Features Histogram Dialog Box .........cciiiiiiiiiiiiiiiiiiiiiiiineeneennns 79
Snap Dialog BoxX. . ...iiiiiiiiiii ittt i it i ittt ittt 82
View Orientation Dialog BoX ........citiiiiiiiiiiiiiiiiiiiiiirienenenannnns 87
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Matrix Window

To access:

From the Engineering Toolkit: Click the matrix icon in the entity pane.

e

If the product model has no steps, the Create Step dialog box opens. Type the name of
the step and click OK or Apply.

e From Graphic Station, Panel Designer: Choose View > Matrix or click the Open Job’s
matrix tool ().

e From the Valor NPI dashboard: Click the Matrix tool () in the Layer Controls
toolbar.

e From CAM Compare: Choose Tools > Matrix or click the Matrix tool (=).
e From ODB++ Viewer: Click the Matrix tool (=).

The Matrix is a representation of the product model in which the rows are the product model
layers (sheets on which elements are drawn for plotting, drilling and routing, or assembly). You
can customize the Matrix window by moving the panes and toggling their display. The
appearance settings are remembered for future Matrix sessions.

Note
D You can only edit the product model Matrix in the Valor NPI environment.
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Figure 4-1. Matrix Window
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Matrix Window

Objects

Object

Description

Matrix rows

Represent the layers in the product model step. The color reflects the layer
type. The positioning of the layers reflects the layer stackup:

e Top component, silk screen, solder paste, solder mask

Copper layers in their order
Solder mask, solder paste, silk screen, bottom component

Drill layers in sequence from where the drills started, to the largest
depth (largest to smallest), then layer 2 to the largest depth, and so
forth

Rout layers

e Document and misc layers

If HDI technology layers are present in EDA data, they are displayed
above or below the relevant top or bottom component layers.

The color of the drag handle cell to the left of the name is colored green if
there are features on the layer.

Layer contains no features —m = |dielectric_1
Layer contains features —— # |signal_1

Clicking the drag handle cell selects a layer. Selected layers are
highlighted. For more information on the Matrix mouse usage and editing
shortcuts, see Table 3-12 and Table 3-13.

Matrix columns

Display the drill/rout spans and the values for the layer parameters and
attributes.

¢ Drill or rout spans — The left-most column represents the drill and
rout spans, with the arrows indicating the drill direction. This column
cannot be hidden.

There is a span bar for each drill and rout layer. The span bars appear
as solid lines, except for the layers with the subtype “backdrill” whose
span bars appear as dotted lines.

e Layer Parameters — The basic layer characteristics: Type, Subtype,
Context, Polarity, Dielectric Reference, and Reference. See “Layer
Parameters” on page 43.

Click a column header and drag to the desired location. The layer
parameter columns cannot be hidden.

e Layer Attributes — The layer properties that add intelligence to the
product model data. Only the attributes selected in the Layer Attributes
pane are displayed.

Click a column header and drag to the desired location.
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Object Description

Layer Attributes Lists the available layer attributes that you can display as the Matrix

(View > Layer columns. See “Layer Attributes” on page 47.

Attributes) Select or clear the check box in the Show column to include or exclude the
layer attribute column from the Matrix.

Type a string in the Filter field to display only the attributes containing
that string in the Attribute or Values field.

Layer View Displays a thumbnail graphic of the layer selected in the Matrix. See
(View > Layer Table 3-15 for the key combinations and mouse options for navigating and
View) controlling the display.

Usage Notes
e Choose File > Step and select the step to be displayed.

e (Valor NPI environment) Choose File > Save or click to save the product model,
including the modifications you have made in the Matrix.

e Choose Edit > Toggle Units or click g”jﬂ to switch between metric and imperial units.

e Choose View > Refresh or click Hto refresh the screen display.
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Control Dialog Box

To access:

e From Graphic Station, Panel Designer: Options > Graphic Control.

e From Valor NPI dashboard, DFMA Result Viewer: Tools > Options > Graphic
Options.

e From CAM Compare, ODB++ Viewer: View > Control.

e Right-drag down and to the right in the graphic area ( \ ).

Use this dialog box to control the display of data in the graphic area.
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Control Dialog Box

Figure 4-2. Control Dialog Box
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Fields
Field Description
Width Controls how features are depicted in the graphic area.
e On — Displays filled features
e Outline — Displays outlines of features
e Off — Displays skeletons of features
Skeleton is the same as outline for all features except lines and arcs,
where the skeleton is a hairline through their centers from their start
point to their end point.
Ctrl-w toggles among the options.
Negative Data Controls how negative data and positive data is displayed in the graphic
area.
e Show Clear — Negative data erases positive data.
e Show Dim — Negative data is displayed as dimmed.
Ctrl-n toggles between the options.
Layer Display Mode | Controls whether layers are displayed in transparent mode or in opaque
mode in the graphic area.
e Transparent — Layers are transparent.
e Opaque — Layers are opaque. The color of a recently opened layer
overrides underlying colors.
Mixing of overlapping transparent layer colors depends on the operating
system.
Windows — Color mixing is non-realistic.
UNIX — Color mixing depends on the color representation. For True
Color, color mixing is non-realistic. For 8-bit, color mixing is realistic.
Ctrl-m toggles between the options.
Step & Repeat Controls the display when panelization has been performed on a product
Features Display model.
e Yes — Displays the panel and all features of selected layers in their
Step & Repeat sequences.
e No — Displays only Step & Repeat outlines used in panelization.
Drill/Rout Data Controls how drill and rout data is displayed.
Display e Regular — Shows pads in drill layers
e Markers — Shows markers, instead of pads, indicating tool number
(Excellon files)
Marker symbols are customizable.
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Field Description
Dynamic Texts Controls how dynamic text is displayed.
Display e Value — Shows translated value of embedded code. Dynamic texts
can be accessed when adding text features
e Name — Shows code label only without its translated value
Units Controls the units of measurement in which distance values are

displayed.

¢ Inch/mils — Displays distances in inches or mils

e mm/microns — Displays distances in millimeters or microns
Alt-u toggles between the options.

Popview Continuous
Mode

Controls how the magnified view in the Popview window is refreshed.

e Off — Only when the user stops panning
e On — Continuously

Features Histogram

Controls how the features histogram is updated.

Auto Update e Yes — Provides continuous update of the Features Histogram when
features are added or removed
e No — Updates the histogram when you click Update
Slots Histogram Auto | Controls how the slots histogram is updated.
Update e Yes — Provides continuous update of the Slots Histogram when
slots are added or removed
e No — Updates the histogram when you click Update
Graphic Cursor Controls how the mouse pointer is indicated in the graphic area.
e Regular — As a plus sign (+)
e Full Screen — As cross hairs spanning the graphic area
Profile Display Controls the profile display.

e Yes — Displays profile
e No — Does not display profile

Dimension Display

Controls the display of distance indicators on lines in the Rout Profile
Editor.

e Yes — Display distance indicators
e No — Do not show dimension indicators

Chain Display Controls the display of chain layer features in the Rout Profile Editor.
e Yes — Display chain layer features.
e No — Do not display chain layer features.
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Field Description
Compensated Controls the display of the compensated rout layer in the Rout Profile
Display Editor.

e Yes — Display the layer.
e No — Do not display the layer.

Dimension Msg
Display

Controls the display of Rout Profile Editor messages reporting invalid
dimension links, when source or destination elements are modified.

e Yes — Display the messages.
e No — Do not display the messages.

FS & SMT Direction
Display

Controls whether arrows are superimposed in the Overview pane to
indicate top and bottom Flow Solder and SMT direction as set in the
entity attributes of the step.

e Yes — Display the arrows.

e No — Do not display the arrows.
The direction of the arrows viewed from the top layer toward the bottom
layer is determined by the step attributes. These are the directions:

o left2right

e right2left

e top2bottom (vertical direction from the top edge to bottom edge of a
board)

e bottom2top (vertical direction from the bottom edge to top edge of a
board)

These are the step attributes:

SMT Direction (Bottom)

SMT Direction (Top)

Flow Solder Direction (Bottom)
Flow Solder Direction (Top)

If the board is flipped or rotated, the display of arrows changes with the
board.

The default for this parameter is set in configuration parameter
edt disp_fs smt_direction.

Layer Profile Display

Controls how the layer profile is indicated in the graphic area.

e Yes — The layer profile is displayed as a grid of dots.

e Outline — The outline of the layer profile is indicated by a dotted
line.

e No — The layer profile is not indicated (default)
Alt-y toggles among the options.
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Field

Description

Layer Zone Display

Controls how layer zones are indicated in the graphic area.

e Yes — Layer zones are displayed. The areas are labeled. Rigid zones
are a solid color and flex zones are displayed in a pattern.
¢ Outline — The outline of layer zones is indicated by a solid line.
e No — Layer zones are not indicated. (default)
Alt-z toggles among the options.

Related Topics

Configuring the Display

Control Dialog Box Shortcuts
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Component Display Options Dialog Box
To access:

e From Graphic Station, Panel Designer: Options > Components

e From Valor NPI dashboard, DFMA Result Viewer: Tools > Options > Component
Options

e From other viewers: View > Component Options

You can use the Component Display Options dialog box to configure some aspects of how
components are displayed in component layers.

Figure 4-3. Component Display Options Dialog Box
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Objects

Object

Description

Name Display

Defines the type of name to display for components.

RefDes — Reference designator.

If the Placement Layer attribute is assigned, then its value appears
next to the component name, according to the following convention:

<RefDes>[<placement layer>]

The placement layer indication is for display only and does not
affect the component name.

CAD Part — The part number from CAD data.
Package — The package name from CAD data.
None — Do not display a name.

CPN — Customer Part Number from the BOM.
IPN — Internal Part Number.

Manufacturer/MPN — Manufacturer name and part number from
the BOM.

VPL Pkg — Valor Parts Library package name.
BOM Pkg — Package name from the BOM.

Font Size

Defines the font size for the component and pin names.

Overflow Text

Controls whether to allow text to extend beyond the component and pin
outline.
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Object

Description

Show Pins

Controls whether to display leads, and if displayed, the type of
information to show.

e No — Components are displayed without leads.

e Yes — Components are displayed with leads.

e Name — Lead name is displayed on the leads.

e Mount — The mount type is displayed on the lead as SMT,
SMT RP, TH, TH_RH, PRESS FIT, HOLE, or NON_BOARD if
the lead mount type was defined in the EDA translation or VPL data.
If not defined, an alternate value of th, blind, sm, or osm can be

displayed if defined by the EDA translation or VPL data. The lead
electrical type, M or EM, is shown if the lead is mechanical.

¢ Lead Form — If VPL data exists, the shape is indicated on the
leads: A-Post Terminal, B-Butt or Ball, C-C-Bend, D-Lug, F-Flat
Lead, G-Gull-Wing, J-J-Lead, L-L-Bend, M-Column, N-Surface
Lead, O-Pressfit, P-Pin or Peg, Q-Quick Connect, R-Wraparound, S-
S-Bend, T-Through Hole, U-Bend, W-Wire, X-Other, Y-Screw.

e Extended Lead Form — Ifthe VPL data contains the extended lead
form, the following information is displayed:
e On the leads: <Lead Form> / <Extended Lead Form>
e On the component sides: Classification used by analysis: leaded,

unleaded, onedge (treated as leaded), or pullback (treated as
unleaded)

e Lead Edges — If the VPL data contains the extended lead form, the
lead edges are marked as (s)ide, (t)oe, or (h)eel.

Note: Toe/heel determination is missing for VPL components
with no extended lead form data. In this case, the lead edges are
marked as (s)ide or (a)mbiguous.

e Geometry — Leads are marked by their geometry (padstack name).
e Net — Leads are displayed with their net names.

Show Pin #1 Mark

Selected, displays the Pinl mark.

Components Display

Controls the display of components that have the .comp_ignore system
attribute.
e All — All components are displayed.
¢ Placed Only — Components with the .comp_ignore attribute are not
displayed.
This option affects several displays and functions in Valor NPI
dashboard, Graphic Station, Engineering Toolkit, and Export.
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Object

Description

Component Outline

Controls how the outline of the component body is displayed in the
graphic area.
e Body — As a solid line.

¢ Envelope — As a solid line with pins outlined by a dotted line. The
overall outline is the envelope.

e T-envelope — As a solid line with toeprints in outer layer outlined
by a dotted line. The overall outline is the T-envelope.

Pre-VPL Component
Display

Controls the display of original component data (from CAD) before
merging with VPL data, after VPL merge has been performed.
e No — Displays only VPL data, if present.

e Yes — Highlights component data before merging with VPL data, in
addition to VPL data (displayed but not highlighted).

If VPL merge has not been performed, both options display only pre-
VPL data.

Related Topics

Configuring the Display
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Colors Dialog Box

To access:
e From Valor NPI dashboard: Tools > Options > Color Options

e From Graphic Station, Panel Designer: Options > Colors
e From other viewers: View > Color Settings

Use this dialog box to set colors for displaying entities in the graphic area: layers, the
background, features and components when you highlight or select them, and rubberband.

Figure 4-4. Colors Dialog Box

Layers I = General

Layer1d | Background -

Layer 15 Highlight

.La:,,ler 16 Salaet

Layer 17 Rubberband |

| Layer 18 Entity Pane l

Layer 19

.L-l:..'er 20

Layer 21

Layer 22

Layer 23

Layer 24

[ E— (I P— | = il
s Color Picker - 'I

Basic Colors EEEEEEET
Falette EEEEEEC
EEEENENT
EEEENENENT
HEEEENEET
[ F A 0 § Ao

Pick Screen Color I

Saturation Slider

Color Picker
Pane

-
L} Color Models
Cussteen colors Hoe: [o = Red: [2s5 5]

i sat: [0 = Greem: [255 -4
R | e

Add to Custom Colors | L P
[ e | s | ek | mewy | ok |

Custom
Colors Palette

HTML Color
Code
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Description

The Color Picker pane displays the color for the entity selected in the Entity pane.

Objects

Table 4-1. Colors Dialog Box - Entity Pane

Field

Description

Layers

Displays the color of features and components that reside in the layers
displayed in the graphic area. The layers are listed in the order of display
(Layer 1 - Layer 25). Click a layer to select it.

General

Displays the color of the following entities:
e Background — The background of the graphic area
e Highlight — Features and components when you highlight them
(<)
e Select — Features and components when you select them
(o L] I 0O

¢ Rubberband — The shape outline that dynamically tracks the mouse
pointer movement when you move a feature or a component

Click an entity to select it.

Table 4-2. Colors Dialog Box - Color Picker Pane

Field

Description

Basic colors palette

Displays pre-defined common colors as boxes. Click a color box: the
fields in the Color Picker pane are updated to reflect the change.

Custom colors
palette

Displays previously saved user-defined colors as boxes. Click a color
box: the fields in the Color Picker pane are updated to reflect the change.

Color picker

Displays an array of colors. Click inside the field: the cursor changes to
crosshairs and the fields in the Color Picker pane are updated to reflect
the change.

Saturation slider

Enables you to adjust the intensity of the selected color. Click and drag
the slider up or down: the fields in the Color Picker pane are updated to
reflect the change.

Custom color
rectangle

Displays a preview of the current color.

Color models

Displays the HSL and RGB values for the current color.

HTML color code

Displays the hex value for the current color.
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Table 4-3. Colors Dialog Box - Action Buttons

Button Description

Pick Screen Color Enables you to pick a color from any region of your screen. Click the
button and then click the desired location: the cursor changes to
crosshairs and the fields in the Color Picker pane are updated to reflect
the selected color.

Add to Custom Saves the current color to the Custom colors palette.

Colors

Load Loads a previously saved color scheme.

Save Saves the current color settings in a user-defined color scheme file at the
user, design center, or system level, or at any location on the file system.
The default name for a color scheme file is colors.

Default Reverts to the system default colors.

Apply Applies the current color to the selected entity. The color scheme
remains throughout the session.

OK Closes the dialog box and applies the color settings.

Cancel Closes the dialog box without changing the colors.

Related Topics

Configuring the Display
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Component Information Dialog Box

To access: Select or highlight a component in the graphic area and then perform the action
appropriate for your interface:

e From Valor NPI dashboard, choose Edit > Feature Info.

e From Valor NPI dashboard, DFM Result Viewer, Graphic Station, Panel Designer, click
the data bar.

e From any interface, click the info button ( @) in the toolbar.

You can use the Component Information dialog box to view information about the component
selected or highlighted in the graphic area. The dialog box consists of the following panes:
Identification, DESCRIPTION, ATTRIBUTES, and PROPERTIES.

Getting Started With ODB++Design, vNPI 2305 69
May 2023

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.



GUI Reference
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Figure 4-5. Component Information Dialog Box

Component Information

Top Components

Comp # 250 : UlE

Parc : 4610-D053

EDA Package : BGAES lmm

BOM INFO:

CPH : 4610-D053

IFH H

MFPH : BC48F4400P0TBOOA
Manufacturer : INIEL

BOM Package : BGRE4 1MM

VPL INFO:

MFH i BC48F4400PO0TBOOA
Meoode : INIEL

VPL Package ! "BGA-BE64/P-L100W1l30T1l3

Package Type : GRID ARRAY
Part SubType : Memory
Lead Type : Ball/Butc

DESCRIFTION e

descl: INTEL 32MX16, RC4BFP4400P0TEODA,; PACEAGE E€4-EZBGA

J 3

ATTRIBUTES

Filrer: |

Mount Type = amt (C) -
Package Type = ga (C) -
Folaritv = oolarized (C)

4 [
FROFERTIES

Filter: |

VEL PACEAGE TYPE = BGRA e -
PAEEAGE_TYPE—bHaater_ﬂa.mple_‘i’]?r. = BGEA

PRCEAGE TYPE->Master Sampls VEL MM = BGA
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Objects
Object Description
Identification Lists the component identifiers derived from various sources.

e Information in the CAD data:
e Layer — The layer in which the component resides
Index — The index number of the component
RefDes — The reference designator of the component
Part — The part number of the component
e EDA Package — The name of the package
e BOM INFO:
e CPN — The customer part number of the component
e IPN — The internal part number of the component
Manufacturer — The manufacturer of the component
e BOM Package — The name of the package
e VPL INFO:
e MPN — The manufacturer’s part number of the matched part

Mcode — The name representing all variations of the
manufacturer’s name for the matched part

VPL Package — The name of the matched part’s package
Package Type — The type of the matched part’s package
Part SubType — The subtype of the matched part
Lead Type — The type of the matched part’s leads

View image/

(If available) Displays in a browser the component’s image and/or

Datasheet datasheet on the manufacturer’s web site.

DESCRIPTION Lists the values in the description fields in the BOM: descl...10.

ATTRIBUTES Lists the attributes with Entity = “Component” or “Package” that have
been assigned manually, at CAD input, or during analysis.
In the Filter field, type a string to display only the attributes containing
this string in their name.

PROPERTIES Lists the properties in the Component and Package groups that have been

assigned at CAD input or during analysis.

In the Filter field, type a string to display only the properties containing
this string in their name.

Related Topics

Viewing Component and Feature Information
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Feature Information Dialog Box

To access: Select or highlight a feature in the graphic area and then perform the action
appropriate for your interface:

e From Valor NPI dashboard, choose Edit > Feature Info.

e From Valor NPI dashboard, DFM Result Viewer, Graphic Station, Panel Designer, click
the data bar.

e From any interface, click the info button ( 'ii:') in the toolbar.

You can use the Feature Information dialog box to view information about the feature selected
or highlighted in the graphic area. The dialog box consists of the following panes: Geometry,
Attributes, and Net Properties.

Restriction
When accessed from the Valor NPI dashboard by selecting a feature that has previously

been highlighted, the Feature Information dialog box is empty.
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Description

Figure 4-6. Feature Information Dialog Box - Pad

Feature Information

Layer : d 12 13

Pad 157

X = 3.503537
o = Z.4405445%
Symbol = rf
Bolarity = POSITIVE
Deaode =1

Lngle =10

Mirror = HNo

Lead Form

Lspect HRatioc = 4:1
Finished size = r&
ODrilled =ize = rf

Drill Type = wvia

Geometry = viald_ 3

Pad Usage = wia

Padstack ID = 172877

Padstack optimized after NFP removal
Via Type = drilled

Het - GND (2/5172(5/77) Via)
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Figure 4-7. Feature Information Dialog Box - Line

Feature Information

Layer : plane 1

Line #£343

XS = L5.82&677TL7

¥s = 1.59%E68503%

XE = 4,1732283

YE = 1.59%E8503%9

Length = 1.654 (13.45/147)
Symbol = rl2

Palaritcy = POSITIVE

Doode = 0

Shorted necs:
JDATA BIT 4
/DATA_BIT 5

Net : SDATA _BIT 5 (54/3(3/5) Trace)

Het Type = Power
Max. Stub Length = 0.3 ™

Figure 4-8. Feature Information Dialog Box - Arc

Feature Information

Layer : mpd

Are §#374

xC = —0.10786
¥C = 0.2385967
XS = -0.1112205
¥S = 0.23855967
XE = -0.1102362
YE = 0.2362205
Diamecer = 0.006721
Length = 0.002&3%
Symbel = r2.756
Polarity = POSITIVE
Deode = g

Sweep = 45 CCW

Het : DAT RPD 2 (351/7(1/1) Trace)

S30A Critical Het

Het Type = FAIR
Differential Pair = DF18
Electrical Clas= = DIFFFAIR
Net Physical Type = PAIR
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Figure 4-9. Feature Information Dialog Box - Surface

Feature Information

Layer : plane 1
Surface §l564%

%C = 2.5688076

¥C = £.072834€

¥ Size = 1.£338583

Y Size = 0.3346457

Area = 273412.611 sg.mil
Perimecer= 4,4425001 inch
Polarity = POSITIVE

Deocde = 0

Islands = 1

Holes =1

Edges = 27

Het : 12V SW (7/14(1/1) Plane)

Het Type = Power_ 3 x (Default)
Max. Stub Length = 0.3 ™
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Objects

Table 4-4. Feature Information - Pad

Object Description

Geometry (Pad) Provides detailed information about the pad geometry.
See Figure 4-6.

e Layer — The layer in which the pad resides.

e Index — The index number of the pad.

e X, Y — The coordinates of the pad.

e Symbol — The symbol used to create the pad.

e Polarity — The polarity of the pad.

e Dcode — The Dcode of the pad.

e Angle — The angle of rotation of the pad.

e Mirror — The mirroring of the pad.

e Lead Form — The form of the lead associated with the pad.

e Aspect Ratio — The ratio of the drill depth to its diameter.
Displayed only for round drill pads that have a non-zero radius and
whose span (cumulative thickness of the pierced copper and
dielectric layers) is greater than zero.

¢ Finished size — The size of the hole after plating, as determined by
the Drill Tool Manager (DTM) status:

e DTM applied — The Finish Size in the drill tool table.
e DTM not applied — The symbol value.

e Drilled size — The size of the tool used to create the hole, as
determined by the Drill Tool Manager (DTM) status:

e DTM applied — The Drill Size in the drill tool table.
e DTM not applied — No value is displayed.

Geometry (Line) Provides detailed information about the line geometry.
See Figure 4-7 on page 74.

e Layer — The layer in which the line resides

e Index — The index number of the line

e XS, YS — The coordinates of the line start

e XE, YE — The coordinates of the line end

e Length — The length of the line

e Symbol — The symbol used to create the line

e Polarity — The polarity of the line

e Dcode — The Dcode of the line
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Table 4-4. Feature Information - Pad (cont.)

Object

Description

Geometry (Arc)

Provides detailed information about the arc geometry.
See Figure 4-8 on page 74.
e Layer — The layer in which the arc resides
e Index — The index number of the arc
e XC, YC — The coordinates of the arc center
e XS, YS — The coordinates of the arc start
e XE, YE — The coordinates of the arc end
e Diameter — The arc diameter
e Length — The arc length
e Symbol — The symbol used to create the arc
e Polarity — The polarity of the arc
e Dcode — The Dcode of the arc
e Sweep — The sweep angle the arc

Geometry (Surface)

Provides detailed information about the surface geometry.
See Figure 4-9 on page 75.

e Layer — The layer in which the surface resides

e Index — The index number of the surface

e XC, YC — The coordinates of the surface

e X Size, Y Size — The size of the surface in the X and Y directions

e Area — The area of the surface

e Perimeter — The total length of the surface contour

e Polarity — The polarity of the surface

e Dcode — The Dcode of the surface

e Islands — The number of islands contained in the surface

e Holes — The number of holes contained in the surface

e Edges — The number of edges contained in the surface

Shorted Nets

Lists the names of the nets that are shorted together by the feature.

Note: Shorted nets information is only displayed for features defined
in the short definitions file as creating intentional net shorts within
the product model.

See Figure 4-7 on page 74.

Attributes

Lists the attributes that have been assigned to the feature at CAD input or
during analysis.
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Table 4-4. Feature Information - Pad (cont.)

Object Description

Net Provides the net information for the feature.

e In Figure 4-6 on page 73, the Net GND is found on net #1, which has
976 subnets. This selected feature is a via. It is the first of the two
features on the net. (1/2).

e In Figure 4-7 on page 74, the Net DATA BIT 5 is found on net #54,
which has three subnets. This selected feature is a trace. It is the third
of the five features on the net. (3/5).

e In Figure 4-8 on page 74, the Net DAT RPD 2 is found on net #351,
which has seven subnets. This selected feature is a trace. It is the first
and only feature on the net. (1/1).

e In Figure 4-9 on page 75, the Net 12V_SW is found on net #7, which
has 14 subnets. This selected feature is a plane. It is the first and only
feature on the net. (1/1).

Net Attributes Lists the net attributes of the feature.

Net attributes are always shown in inch, regardless of the units specified.

Related Topics

Viewing Component and Feature Information
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Features Histogram Dialog Box

To access:

e From the Layer List, right-click a layer name in the Layer List and choose Features

Histogram.

e From the Features Search/Features Filter window (Editor configuration), click the
Select button, and then click the Histogram button.

You can use the Features Histogram dialog box to select, highlight, or search for features

residing in a layer of type Standard, Drill, or Rout.

Figure 4-10. Features Histogram Dialog Box

Features Histogram

Layer : layerll
Edit
name count
i Total 7380

+1- Lines 1439

-1 Pads 57a0
r19.685 POS r=0.000 2066
r21.654 POS r=0.000 2671
r25.669 POS r=0.000 b
rd5.354 POS r=0.000 2
r51.26 POS r=0.000 ]
r53.228 POS r=0.000 19
r57.165 POS r=0.000 15
r63.071 POS r=0.000 63
r65.030 POS r=0.000 2
ri7.835 POS r=0.000 24
r194.961 POS r=0.000 12
oval90.551:47.244 POS r=270,000 2

+1- Surfaces 153

+1- Arcs T

! | B

Eelect | Highlight |
Update
Unselsct | Turn OFff |

Expand 211 | Collepse

Description

The behavior of the Features Histogram dialog box differs depending on how you invoke it:

e  When invoked from the Features Histogram popup menu item, the dialog box displays

all features residing in the specified layer.
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e  When invoked from the Histogram button in the Features Search or Features Filter
dialog box, the dialog box displays only the selected features that match the filter criteria
specified.

Tip
You can activate continuous update mode by setting the Features Histogram Auto Update
option to Yes. See “Control Dialog Box™ on page 56.

Note
If you do not use feature selection tools, filters apply to all features in the Affected layers.

Objects

Table 4-5. Features Histogram Dialog Box

Object Description

Feature tree The features of the layer appear as tree nodes, grouped by
type (lines, pads, surfaces, and text). For each feature, the
following information is displayed:

Polarity
e Resize

Degree of rotation
e Count
Select one or more nodes and click one of the action buttons.

Select Prerequisite: The selected layer is an Affected layer or Work
layer.

Cumulatively selects all features of the type selected in the
Feature tree.

Unselect Prerequisite: The selected layer is an Affected layer or Work
layer.

Unselects all features of the type to which the last selection
action was applied.

Highlight Highlights all features of the type selected in the Feature tree.

Turn Off Removes highlighting from all features of the type to which
the last highlight action was applied.

Update Refreshes the histogram to reflect the specified layer and filter
criteria (if applicable).

Expand All Expands the Feature tree to all levels.

Collapse Collapses the Feature tree.
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Related Topics
Using the Features Histogram to Select or Highlight Features
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Snap Dialog Box

To access:

e From Valor NPI dashboard, DFM Result Viewer: Edit > Snap

e From Graphic Station, Panel Designer: Options > Snap

e From any interface: Control Snapping tool ()

You can use the Snap dialog box to control whether the grid is displayed, and in what form. You

can control how items snap to positions on the grid or to other items.

Description

Factors Affecting Snapping

Factor 1: Item Type

Figure 4-11. Snap Dialog Box

Snap Features
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Qff

Snapping depends on the type of item selected, its snap point, and the distance to the nearest

snap point.
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Table 4-6. Items to Which Snapping Applies

Item Snapping Location
Grid At grid intersections.
Feature Line, Pad, Surface (area, polygon), Arc — According to the
current Snap mode as shown in Table 4-8.
Text — To the beginning of the baseline: _}Arq
Reference layer in CAM | A reference layer affected by the Move Layer action is highlighted
Compare with a rubber band. A click inside the rubber band sets the snap point

to one of the following:

e The mouse cursor position (Snap mode = Off)

e The closest board feature as shown in Table 4-8
(Snap mode # Off)

Step in an assembly
panel (if Panelization
mode = Manual)

If Snap mode = Off, the selection of a step snaps to the nearest vertex
on the board profile if clicked inside the step in proximity, otherwise,
no snap is performed.

If Snap mode # Off, snapping is performed as follows:

¢ Clicking inside a step snaps according to the current Snap mode
to the nearest board feature in the current Snap and Work layer.

e Clicking outside of a step snaps to the panel features of the
current Snap layer.

Factor 2: Snap Mode

The appearance of the Control snapping tool reflects the current snap mode.

Table 4-7. Snap Modes

Snap Mode | Appearance | Shortcut Snap Location
of the Tool

Off SO Snap mode is off

Grid SG Nearest grid intersection

Center ﬁ SC Center of a pad (end of an arc or line)

Skeleton ﬁ SS Skeleton hairline in the center of a line or
arc, or to the center of a pad

Edge ﬁ SE Closest edge of a feature (also lines and
arcs)

Intersect ﬁ SI Intersection of lines or arcs

Midpoint ﬁ SM Midpoint of lines (not arcs) or the center of
pads and filled surfaces
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Table 4-7. Snap Modes (cont.)

Snap Mode | Appearance | Shortcut Snap Location
of the Tool
Profile ﬁ SP Closest point on the defined profile
Between ﬁ SB Center of an orthogonal (horizontal or
vertical) line between two closest pads

Factor 3: Snap Layer

Snapping only applies to items residing in the Snap layer, as selected with SA (Snap Advance).
A small grid symbol indicates that a layer is the Snap layer:

_drl B -

Figure 4-12. Snap Features
7 e |m |~

| Pad | Arc
Line Surface Text

Snap Features

JuL a

The snap points for a line, pad, surface, or arc depend on the specified Snap mode.
Table 4-8. Feature Snap Points Per Snap Mode

Snap Line Pad Surface Arc

Mode

Center to ends to center to center to ends
!ﬁ

Skeleton to skeleton to center to center to skeleton

(——)

A

Cd

Edge to closest edge to closest edge to closest edge to closest edge

:
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Table 4-8. Feature Snap Points Per Snap Mode (cont.)

Snap Line Pad Surface Arc
Mode
Intersect to intersect no snap no snap to intersect
Midpoint | to midpoint to center to center no snap
4
Grid Display

Table 4-9. Grid Display

Appearance Option Image

Marks + + + + + + o+ o+
+ + + + + + + +
+ + + + + + + +

Net ]
iEEEEEEES
IHINENEEEE

[ I
Dots
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Objects

Table 4-10. Snap Dialog Box

Object

Description

Snap Features

Buttons to exclude features of specified types from snapping.

The initial state of the buttons is selected, that is you can snap
to features of all types. For example, if you click to deselect
the Arc button, then features in the display will not snap to
arcs.

Snap Mode

Options to specify Snap mode as described in Table 4-7.

Grid

Controls for setting the grid display.

Off — Displays or hides the grid.
Marks — Displays the grid as plus signs (+) at grid
intersections.

Net — Displays the grid as horizontal and vertical lines.

Dots — Displays the grid as dots at grid intersections.

X size, Y size — Specify the distances between grid
intersections along the X and Y axes.

Origin

Changes the graphic origin to the clicked location in the
graphic area.

All items in the graphic area are displayed according to the
specified origin, without changing the origin of the product
model.

Prev Origin

Reverts to the product model origin.

Related Topics
Snap Hot Keys

Measuring Distances
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View Orientation Dialog Box

To access:

e From Graphic Station: g

e From other viewers: Actions > View Orientation

Use the View Orientation dialog box to control the display orientation of the board.

Figure 4-13. View Orientation Dialog Box

View Orientation — | x

(1|
]| [

REset

Rotation: a
Objects
Object Description
¢ | Rotates the board 90 degrees clockwise.

Rotate Clockwise

2

Rotate Counter-Clockwise

Rotates the board 90 degrees counterclockwise.

Flips the board left to right (left/right mirror).

F
mor (Y axis)
el Flips the board top to bottom (mirror top/bottom).
—
Mirror (X axis)
Rotation Indicates the board rotation.
Mirror Indicates whether the board has been flipped.
Reset Returns the display to the original orientation.

Usage Notes

When rotating or mirroring, the center of the display is always maintained in the center.
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Chapter 5
Troubleshooting

Use this chapter to help fix issues that can occur when working with ODB++Design
applications.

Helpis Inaccessible .........iuiiiiiiiiiiiiiiiiiiiiireeeneeneenesnssnsonsns 89
Text Scaling Issues on Windows 10 .........ciiiiiiiiiiiiiiinrenrenronronnns 89
Display Colors are Not Correct .......covtiitiiiireeeeeseesessnssnssnsonsns 920
Profile is Not Visible in Graphic Area.............cciiiiiiiiiiiiiiiinrenrnnnns 920

Help is Inaccessible

Clicking More Manuals from inside the Help system should enable you to open a manual that
you select from the list.

Symptoms

After choosing Help > Open <Product> Help, clicking More Manuals opens a list of all
product books, but clicking any one of the books opens the first book in the list.

Causes

The popup blocker causes the manual list to redirect all choices to the first book in the list.

Solution
Turn off the pop-up blocker.

Related Topics
Accessing Help From Your Installed Application

Text Scaling Issues on Windows 10

Valor NPI menu text may appear too small on high-resolution monitors (such as laptops with
4K resolution).

Solution
Turn off the setting for fixing blurry apps:

1. Choose Start > Settings > System > Display.
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Troubleshooting
Display Colors are Not Correct

2. Under “Scale and layout,” click Advanced scaling settings.

3. Under “Fix scaling for apps,” turn off the option “Let Windows try to fix apps so they’re
not blurry.”

Display Colors are Not Correct

Display colors in the Valor NPI Graphic Station are not what you expect.
Symptoms
e Selected features are not displaying in the chosen color.
e QGraphic Station display colors are different from those defined.

Causes

The color of selected, highlighted, or overlapping features is usually a mixture of the defined
display colors.

Solution

In UNIX, if you want the selection color, highlight color, and rubber band colors to be a
separate and consistent color, specify this in configuration parameter gui_color no mix.

In Windows, when Layer Display Mode = Transparent, layer features are given some
transparency and the colors of overlapping features are mixed. This helps to emphasize
overlapping features. When Layer Display Mode = Opaque, the colors are not mixed and the
color specified for select, highlight, and rubber band is used. See “Control Dialog Box™ in
Getting Sarted With ODB++ Design.

Related Topics
Configuring the Display

Profile is Not Visible in Graphic Area

The profile may not display if the highlight color is close to the background color.
Symptoms
e The profile is not visible in the graphic area.

e Choosing Edit > Create > Profile does not seem to create a profile.

Causes

The profile color might be set to the same color as the background color.
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Troubleshooting
Profile is Not Visible in Graphic Area

Solution

Choose Options > Colors.

In the Colors dialog box, compare the Background to the Highlight color that controls the
profile color. If they are the same, or very close, change one or the other.

Related Topics
Configuring the Display
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Troubleshooting
Profile is Not Visible in Graphic Area
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Glossary of Valor NPl Terms

alias
Alternate name used for a part manufacturer.

Assembly Merge
Consists of BOM Merge, VPL Merge (also referred to as Library Merge), and Board Merge.

see BOM Merge, VPL Merge, and Board Merge.

Board Merge
A stage of Assembly Merge that re-engineers EDA data, determining the features and nets
connected to each component pin. Same as Component Linking.

see Assembly Merge.

Board Mark
Marks placed on a board to indicate whether the board can be manufactured (good board mark)
or not (bad board mark).

BOM Merge
A stage of Assembly Merge that merges the BOM with the board.

see Assembly Merge.

broken
Missing section of an electric circuit.

BTE
Valor NPI BOM Template Editor. Used to create templates for parsing a customer’s BOM input
files from their original format. You can use a single template to parse similar BOM files.

Checklist
Set of DFx Analysis check actions and their results.

Chosen part
When an IPN has more than one part in the BOM, the Valor NP1 BOM Manager chooses one of
the parts as the Chosen part. Users can override the system-defined Chosen part.

Component Identifier
Any of the ways by which a component can be identified, such as: CPN, CAD-CPN, IPN, MPN,
Package, RefDes, Station, and Angle.

Component Linking
Re-engineers EDA data, determining the features and nets connected to each component pin.
Component Linking can be performed on a Board or a PCA. Same as Board Merge.
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contour
A shape created by merging multiple features.

CPN
Customer Part Number. Represents the part number requested by the customer who provided the
design to be manufactured. This can be the same as the IPN or can be mapped to a number of
different IPNs, depending on the origin of the CPN.

Design Center

A directory under $VALOR_DIR that represents a physical plant of the customer who provided
the design to be manufactured. The application can be customized for designs coming from a
particular design center.

DFA

Design for Assembly. Designing a product so that it can be assembled efficiently at an optimal
cost and highest yield.

DFF

Design For Fabrication. Designing a product so that it can be fabricated efficiently at an optimal
cost and highest yield.

DFM

Design For Manufacturing. Designing a product so that it can be fabricated efficiently at an
optimal cost and highest yield. It is often used to represent both DFA and DFF. The term is used
to represent algorithms that can make automated modifications to the PCA based on a set of
rules.

DFT
Design For Testing. Designing a product so that electrical tests can be performed. This includes
creating points on the outer layers of the board that are used to test how electrical current travels
from one point to another through the inner traces of the board.

DFx
Includes all types of Design for eXcellence: Design For Assembly, Design For Fabrication,
Design For Manufacturing, Design For Testing.

DRC
Design Rule Check. Pass-or-fail checks based on design constraints. Normally used by EDA
vendors.

Drill span
The layers through which a drill passes.

Drill type
A drill attribute with one of these values:

e Via — Connects several layers.

e Non-Plated — Through-hole (TH) drill type without electrical connectivity.
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e Plated — Through-hole (PTH) drill type with electrical connectivity. Used for
components legs.

Feature Data
A primitive that can be drawn on the layer: line, pad (a specific symbol flashed at a point),
surface (a linear path with a specific width), text.

Flattening
Displaying all data of a panel with multiple Step & Repeat sequences, as one step. This is
necessary for assembly machines that cannot process Step & Repeat information.

Footprint
The pattern and space on a board taken up by a component, as defined by its body shape and pads
(contact area of component legs with the board).

see Toeprint.

IPN
Internal Part Number. The number used on the assembly floor to identify the parts to be supplied
to the machines and put on the boards. The IPN is typically unique for each contract
manufacturer.

Keepin/Keepout Areas

Areas of a layer where components and test points are allowed to be included or excluded, which
activates the reporting of components or test points that are located in invalid areas. Keepin/
Keepout areas are typically imported with EDA data.

Layers

Board layers contain graphics, attributes and annotation. Layers represent physical board layers,
NC drills and route layers, and miscellaneous drawings. All the boards in one PCA have the
same list of layers, although the contents may be different.

Library Merge

A stage of Assembly Merge that reads package data from the validated BOM, copies VPL
packages from the BOM package collection to the PCA package collection, and positions the
packages on the PCA at their RefDes location in the correct orientation. Same as VPL Merge.

see Assembly Merge.

Manufacturer
Name of the supplier of the part, provided in the imported BOM data.

Manufacturer Alias List
A list in the VPL used to establish the MCode for a manufacturer name listed in the BOM.

For example, the name Duck Instruments might be represented as any of these: Duck
Instruments, Duck Instr, D-I, DI.
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The manufacturer alias list would list the alias DI for all variations of the manufacturer name:

Manufacturer MCode

Duck Instruments DI

Duck Instr DI
D-I DI
DI DI

When the system processes a BOM file, it matches any one of the Duck Instruments name
variations with the standard MCode (DI) as defined in the VPL. The result is that the BOM has a
consistent Manufacturer name list compatible with the VPL and with VPL-MPN numbers.

Matrix
Represents the layers in a step.

MCode
An abbreviated name used in the VPL to represent all variations of the manufacturer name. The
result is that the BOM has a consistent Manufacturer name list compatible with the VPL and
with VPL-MPN numbers.

MPN
Manufacturer Part Number. The number used by the manufacturer to identify the part.

Net Connectivity
Information about electrical nets and their reference to actual copper features.

ODB++Design (ODB++)
Open Data Base is a CAD/CAM format that captures all CAD/EDA database, assembly, and
PCB fabrication knowledge in a single, unified database.

Part Number
Identifies a component uniquely, within a certain inventory.

Part Package
The geometric characteristics of a component/part. Several parts (unique part numbers) can have
the same package.

Placement sequencing
Determining the sequence in which the components are placed on the board.

Polarized
This BOM column indicates whether the orientation of the part is significant.

Preference

A rating for each alternate MPN of an IPN, to indicate which is preferred: Preferred, Qualified,
Unknown (default), NotQualified. This information is used to establish the Chosen part among
alternate MPNs for an IPN.
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Profile
The PCB outline, typically defined in the CAD data and imported with the product model. It is
normally defined as the outline of the PCB and follows the route path.

Recommended pads
Parts for which pin contact area data is not available, and recommended pads are proposed
instead. You can specify whether packages with recommended pads are included. An asterisk is
added to the end of the name in the BOM Manager if the package contains recommended pads
(for example, PDSO-C2/XX-L58W45T31%*).

Same Net Spacing
Reports non-touching, non-text features belonging to the same layer which are closer than a
predefined parameter.

Set Origin
After importing a CAD design, you can set the board origin to a different point. The origin can
be set at a corner, or any other point on the board. Changing the origin offsets the coordinates of
all features in the graphic display.

SIP
Self-Intersecting Polygon.

Slivers in copper planes
Areas in which the spacing between two lines or a line and a component is so close that they can
potentially cause shorts. Slivers can also be formed in the etch resist when a trace leaves a
termination at an acute angle. This sliver can then lift, causing a violation.

Stubs
Unconnected line endpoints.

Toeprint
The pad of one leg of a component. A footprint is made up of a number of toeprints.

see Footprint.

Tooling
Items unique to the PCB design that are necessary for manufacturing such as films, drilling and
routing data, and text fixtures.

VLM
The VPL Manager (VLM) application manages a local VPL database and the content retrieved
from the central Mentor Graphics VPL. VLM provides tools to search, modify, create, and
update the VPL database and its contents.

The VPL is typically accessed by specifying a component identifier, which includes the
component Manufacturer and the Manufacturer Part Number (MPN). The connection between
manufacturer data, part data and package data is maintained by the MCode and VPackage Name
that are stored in each part definition.
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VPL
The Valor Part Library is a database containing the physical descriptions of components.

Replacing CAD-drawn component packages with geometrically accurate component packages
ensures accurate Design for Assembly (DFA) checks such as those performed using Valor
products. In addition, the accurate geometry serves as a basis for the Auto-Generation of SMT
Machine part data.

The VPL provides accurate physical models of electronic components supporting footprint
generation, DFM, and NPI (New Product Introduction) operations. It includes VPL
Manufacturers and VPL-MPNs. You can work with a local VPL and with the remote VPL at
Mentor Graphics.

VPL Manufacturer
Name of the manufacturer in the BOM after retrieval from the VPL.

VPL Merge
A stage of Assembly Merge that reads package data from the validated BOM, copies VPL
packages from the BOM package collection to the PCA package collection, and positions the
packages on the PCA at their RefDes location in the correct orientation. Same as Library Merge.

see Assembly Merge.

VPL Package
Name of package in the BOM after retrieval from the VPL. This information is used to establish
the Chosen part among alternate MPNs for an IPN.
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Glossary of Electronics Industry Terms

Aperture file
A Gerber wheel file contains external Gerber information as lines of text, each representing one
or more Dcode descriptions. Dcodes contain the symbol information missing from the Gerber
files, because Gerber 274D files refer only to position. Gerber 274X has the aperture file
embedded in the layer files, making the aperture file unnecessary.

see Dcode.

Artwork
An accurately scaled configuration used to produce the artwork master or production master.

Assembly
The process of attaching electronic components to a PCB to create a PCA.

see also Fabrication.

AVL
Approved Vendor List. A list of alternate (functionally equivalent) parts for each CPN that are
acceptable to the customer. At minimum, the list includes CPN, Vendor, MPN, with a
relationship of many Vendor/MPN combinations per CPN. The AVL can be part of the BOM or
a separate file. If the BOM data and AVL data are provided in separate files, you can import
them to the same PCA and merge them.

see also BOM, CPL.

axial

Components whose two pins extend from opposite sides of the body along the horizontal axis of
the body.

seealsoradial.

BGA
Components that have all their terminations on the bottom.

see also Component, DIP components.

Board
Contains all the information associated with a printed circuit design.

see Route.

Body
Main part of an electronic component, excluding its pins.
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BOM
Bill of Materials. A list of parts to be placed on a board with details identifying each part and its
placement on the board. Normally contains Customer Part Number (CPN) and component
location on the board (Reference Designator).

seealso AVL, CPL.

Bottom
The bottom side of a PCB.

see also Top.

Bridging
Unwanted electrical connectivity between two pads.

Broken net
An open net where a section has been disconnected.

CAD
Computer Aided Design. CAD data describes the locations of holes and conductors in terms of X
and Y coordinates, hole sizes, and others. It can contain electrical information and netlists. CAD
data has more comprehensive information than CAM data. Shapes are recognizable, self-
contained entities instead of being a collection of lines.

see CAM, EDA.

CAM
Computer Aided Manufacturing or Computer Assisted Manufacturing. Technology in which
machinery receives instructions from a computer. Often this data is in Gerber format. When
CAD output is fed into the CAM device and translated into instructions to the machinery, it is
called CAD/CAM.

see CAD, EDA.

Component
Electronic part attached to a PCB during PCA assembly.

see also BGA, DIP components, .

Copper balancing
Balancing the distribution of the copper density throughout and across the PCB to prevent
bowing and twisting during thermal processing.

CPL
Component Placement List. Holds the X, Y, angle, and side information for each RefDes to
indicate placement on the board.

see also AVL, BOM.
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Dcode
The link between a symbol description and a specific aperture code in a Gerber file. This is
defined in a wheel. Dcodes control whether the light is on or off, and represent the aperture
position on a list or wheel.

see Aperturefile.

DIP components
Dual Inline Packages. Components that have two parallel rows of pins. The term started with
through hole insertion DIPs such as Proms, processors which had two rows of pins that inserted
into holes. SMT DIPs are more commonly referred to as SOICs—Small Outline Integrated
Circuits and other similar packages.

see also Component, BGA, .

EDA
Electronic Design Automation. Formats from which the application can receive CAD data.

see CAD, CAM.

Fabrication
The work done as part of the actual fabrication of the copper layers and other actions performed
on a board before it is ready to receive parts (Drill, Signal, Solder Paste, Solder Mask, and
others).

see also Assembly.

Feeder
A tool used to deliver parts supplied in a reel to an SMT machine.

see Feeder Capacity.

Feeder Capacity
The number of feeder slots available on a machine.

see Feeder.

Fiducial
A marking at any point on the board with no electrical importance (not in the netlist) that is
recognized optically by the assembly machine.

Assists in the optical alignment of an assembly machine to the board. It can help compensate for
slight rotations of the board and in accurate placement of the component. There are three types of
fiducials:

¢ Local fiducial — Relates to a component
e Global fiducial — Relates to a layer

e Panel — Relates to a panel

footprint
The configuration of pads for all pins of a specific component.
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HDI
High Density Interconnect. Boards that use high density methods, such a micro-via, additive
technologies, and others.

Inspection
Manual or AOI/AXI automated visual verification of quality, without electrical testing.

IPC
The Institute for Interconnecting and Packaging Electronic Circuits. The final American
authority on how to design and manufacture printed wiring.

Lead
The pin of a component. Same as Pin.

Line
Ordered collection of assembly machines with their parameters.

mount-type
How an electronic component is attached to a PCB.

see technology, SMT, through-hole.

NC
Assembly machine programming data in ASCII or binary format. NC program files are output
from auto-assembly sessions.

Netlist
Net points and their connectivity definition, normally from the schematic.

Nozzle
The part of the head on an assembly machine that picks up the parts from the feeder and lets go
when they are in place on the board.

NPI
New Product Introduction is the process used to handle new products at the assembly factory or
designer when the first arrive, to check that the boards can be assembled with minimal errors.

NPTH
Non-Plated Through Hole.

see also PTH, Via holes.

OEM
Original Equipment Manufacturer. The original designer of a product or the company that has its
label on the product (for example, Sony, Cisco, Dell).

Package
Definition of the physical dimensions of an electronic component, without taking into
consideration its electrical properties.
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pad
A flat surface used to make electrical contact between a surface mount device and a PCB.

see also trace.

Panel
A sheet of PCB containing several (similar or different) units that will be broken into individual
boards by a break operation. Same as step&repeat, S&R.

Part
An electronic component to be attached to a PCB during assembly to produce a PCA.

PCA
Printed Circuit Assembly. Created by integrating BOM/AVL data with a board. You can create
an empty PCA and attach a board, or you can create a PCA from a board (you can create it with
no BOM if you are importing a separate BOM, or you can create it with a generated BOM
extracted from the CAD part numbers). The PCA is stored under a particular customer and
design center.

PCB
Printed Circuit Board. A board typically made from fiberglass, used for mounting electronic
components. This board, also called a printed wiring board (PWB), has wiring patterns formed
by traces of a conductor, such as copper, fused to the board. These traces provide electrical
connections for components that are mounted on the surface of the PCB or through holes in the
PCB. Examples: motherboard, SIMM, credit card memory.

Pin
A terminal on a component, whether SMT or through-hole. Also called a lead. Ball technology

components (such as BGSs, CSPs, and others) have ball terminations in place of pins. Same as
Lead.

Pin One
The pin that indicates the orientation of the component.

see Pin.

Pinhole
Small copperless gaps surrounded on all sides by copper. Pinholes might cause electrical breaks,
decreased connectivity or undesirable electrical effects.

Pitch
Distance between the centers of a component’s pins.

see Pin.

Power and Ground Layers
(P&G layers) Layers of copper that are fed by electrical voltage or are grounded.

see stackup, Solder mask.
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PTH
Pin through-hole or plated through hole.

see also NPTH, Via holes.

radial
Components whose leads extend from the same side of the component and whose pins usually
form a single line.

see also axial.

RefDes
Reference Designator. The unique name of a placed component. Each CPN can be placed several
times on a PCB; each placement has a unique RefDes.

Rotation
The orientation of a component on the PCA.

Route
The line on which a PCA is cut to separate it from a board or panel.

see Board.

Shorted net
A net that is erroneously connected to another net.

SMD
Surface Mounted Device. A part put on the board which does not fit into any drill holes but
rather connects to pads on the board.

SMT
Surface Mount Technology. A method for attaching components to a PCA by placing them on
the surface of a PCB and then creating solder joints between the component's leads and the
copper pads. Usually the solder joints are created by placing the components on solder paste that
has been screened on the PCB and then passing it through a reflow oven. Alternately, the
components can be glued to the board and then the PCB can be passed through a wave solder
machine.

SMT Programming
The process of creating all the information required for an SMT machine to place all the required
components on a PCA. This includes the placement sequence information, the machine shape
information, and the feeder set-up data.

Solder mask
Plastic material spread on the copper of a circuit board except were the copper should be
exposed, such as the contacts to be soldered, the gold-plated terminals of any card-edge
connectors, and fiducial marks.

see stackup, Power and Ground Layers.
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stackup
The layers of a board arranged according to a specific order.

see Solder mask, Power and Ground Layers.

step&repeat
The repetition of a board on a panel. Same as Panel, S&R.

S&R
The repetition of a board on a panel. Same as Panel, step& repeat.

technology
Type of component: MECH, SMT, THT.

see mount-type, SMT, through-hole.

Thieving Pad - Copper
When copper features are placed on the outside of the board away from any other copper features
(such as fiducials), these will plate excessively during the pattern plating process. To reduce this,
dummy copper feature (or cross hatch patterns) will be placed close by, to thieve this excess
plating and even out the flux density in plating.

see also Thieving Pad - Solder.

Thieving Pad - Solder
When wave soldering leaded SMT devices (such as SOICs) on the bottom of a PCB, a solder
bridge will often form between the last two leads of the device as it exits the wave. To prevent
this, solder thieves are placed on the board at the rear of the SOIC to thieve this excess solder
away, preventing the bridge.

see also Thieving Pad - Copper.

trace
A line or arc forming a part of the electrical circuit.

see also pad.

through-hole
THT technology assembly method of fitting wire leads of components into holes in the PCB. In
the industry, SMT has largely replaced THT.

see mount-type, SMT, technology.
Top

Top surface of a board.

see also Bottom.

Via holes
A hole of one of these types:

e Through — From top to bottom.
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e Blind — Dirilled from one side, ending before reaching the other side. Cannot be seen
from one of the sides of the board.

e Buried — Connects two or more layers in the middle. It cannot be seen from either side
of the board. This is done by drilling the hole before the layers are attached.

see also NPTH, PTH.
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